Pulsa aquí para quitar la publicidad.

PROBLEMA Caida brusca de calidad en audio Bluetooth

Tema en 'Jiayu S3 MTK6752' iniciado por Saikamur, 16 Dic 2015.

  1. Saikamur

    Saikamur Simdualero de Plata

      74
      36
      25 Abr 2013
      Buenos días a todos.

      Os comento un problema que estoy teniendo con unos auriculares Bluetooth (Mpow Swift) en mi S3A con la ROM KitKat de stock.

      Los auriculares empiezan sonando perfectamente, y al cabo de unos minutos, subitamente se empiezan a oir mal. El efecto es el mismo que si el bitrate se hubiese reducido muchísimo. Al cabo de unos minutos y sin hacer nada, de repente empiezan a escucharse bien de nuevo. Y así está todo el rato, ciclando.

      El problema parece específico de este móvil, porque los mismos auriculares funcionan sin ningún problema ni caída de la calidad en una tablet iFive Air con Lollipop, usando las mismas aplicaciones (PowerAmp reproduciendo contenido local y BubbleUPNP reproduciendo contenido de un servidor DLNA).

      Por otro lado, hasta ahora con este mismo móvil no había tenido ningún problema ni con dos altavoces portátiles Bluetooth ni con el audio Bluetooth del coche. Si había tenido un problema con otros auriculares Bluetooth, pero en aquel caso parecía una mala conexión Bluetooth (se entrecortaba constantemente, pero sin pérdida de calidad).



      Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)

      Por ahí he visto en algún sitio que algunos auriculares cambian automáticamente el perfil de A2DP al de HSP (baja calidad) cuando se utiliza el micrófono. Sin embargo, no he visto ninguna aplicación que parezca hacer uso del micrófono e incluso tengo los auriculares sincronizados solo para el audio multimedia, por lo que entiendo que no se debería hacer uso del micrófono. He estado buscando a ver si hay alguna opción para forzar que el perfil sea siempre A2DP, pero no he encontrado nada.

      ¿Alguien está teniendo algún problema con esta ROM y el audio Bluetooth? ¿Hay alguna función para forzar los perfiles A2DP?

      Aunque en algún momento si tengo pensado cambiar de ROM, preferiría no tener que hacerlo de momento.

      Muchas gracias y un saludo
       
    • yossSP

      yossSP Simdualero de Platino

        382
        415
        1 Ago 2015
        En mi caso no tuve ningún problema con la stock 4.4.4 y el sonido con bluetooth.

        Probado con auriculares+micro X-Fit y manos libres Parrot MKi9100.

        Nunca he necesitado cambiar nada en la configuración ni de Android ni de los dispositivos, únicamente me he asegurado de tener activo el modo Bluetoth sin pérdida en Mejoras de sonido, aunque no está documentado que mejora implica, entiendo que mejorará las frecuencias que sirve.

        Ahora estoy con la Lollipop RC1 de Jiayu.de y todo correcto también.
         
      • Saikamur

        Saikamur Simdualero de Plata

          74
          36
          25 Abr 2013
          Yo por el nombre pensaría que activa el uso del codec aptX, pero tengo mis dudas de que la ROM de stock lo soporte... Aunque con los chinos nunca se sabe... :smirk:

          De todas formas no he notado ningún cambio entre tenerlo activado y no.
           
        • yossSP

          yossSP Simdualero de Platino

            382
            415
            1 Ago 2015
            Yo tampoco he percibido cambio, aunque tampoco me he puesto a comparar, y sí que me extrañaría a mi también que este Jiayu tuviera aptX :smile: , además el aptX requiere que emisor y receptor lo soporten, cosa de la que carezco.

            Desde luego el nombre es bien pretencioso como para no hacer nada ("sin perdida"), ya te digo, creo que se refiere a que capa menos las frecuencias donde corta para la transmisión por bluetooth, alguna ROM para mi viejo Galaxy Nexus disponía de esa opción desde KitKat.

            Si te animas los alemanes acaban de sacar la RC2 de Lollipop (ROM OFICIAL - ROM Lollipop 5.1.1 oficial de Jiayu.de (versión actual RC2)) :wink:
             
            Última edición: 16 Dic 2015
          • Saikamur

            Saikamur Simdualero de Plata

              74
              36
              25 Abr 2013
              Le tengo echado el ojo y la sigo desde hace tiempo en XDA, pero hasta que no se solucione el problema con la banda 900 3G en los modem LL no voy a dar el salto. Es un tema crítico para mi.

              Pero estas navidades que espero tener tiempo posiblemente le meta alguna de los ROMs KK AOSP que hay por ahí, a ver si mejora. Tengo aún hasta febrero para devolver los auriculares (Amazon es una maravilla para eso) y quiero darles otra oportunidad, porque me gustan bastante.
               
            • paki pakidermo

              paki pakidermo Simdualero de Oro

                111
                44
                20 Jun 2015
                yo tengo experiencias similares con el S3. En KK era peor, en LL mejora pero no se soluciona del todo. A mi me pasa con la radio del coche, pero es solo la combinación Jiayu S3 con mi radio. Con el coche de mi colega, funciona bien. Con el mio, parece como tu has dicho que el A2DP cambia el bitrate a baja calidad, y he probado todo, pero nada. Ahora llevo la ROM gnomo V 1 . mañana pruebo y digo, puedo avanzar que la RC1 lo hace pero poco.
                 
              • Saikamur

                Saikamur Simdualero de Plata

                  74
                  36
                  25 Abr 2013
                  Tiene pinta entonces que tendrá alguna incompatibilidad con algunos dispositivos... ¡Que vivan los estándares!

                  Al final acabaré devolviendolos y probando con otros...

                  Enviado desde mi JY-S3 mediante Tapatalk
                   
                • paki pakidermo

                  paki pakidermo Simdualero de Oro

                    111
                    44
                    20 Jun 2015
                    La Gnomo V1 igual que las otras...
                     
                  • Saikamur

                    Saikamur Simdualero de Plata

                      74
                      36
                      25 Abr 2013
                      Finalmente he actualizado a la RC4 y se ha solucionado el problema.

                      La conexión no llega a ser perfecta, con esporádicos clacks y microcortes. Pero al menos la caída de calidad no se produce.

                      Para el uso que le voy a dar, al menos ya son funcionales. A ver si con sucesivas actualizaciones termina de quedar perfecto.

                      Enviado desde mi JY-S3 mediante Tapatalk
                       
                      • Me Gusta Me Gusta x 1
                      Verificación:
                      Borrador guardado Borrador eliminado

                      Compartir esta página

                      Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.