Pulsa aquí para quitar la publicidad.

IMPOSIBLE HACER ROOT DEL LENOVO P770 - AYUDA !! Gracias.

Tema en 'Lenovo P770 MT6577' iniciado por Jon, 29 Mar 2013.

  1. Jon

    Jon Simdualero de Bronce

      20
      0
      18 Sep 2011
      Hola, he seguido las instrucciones similares a las indicadas aquí http://bm-smartphone-reviews.blogspot.nl/2012/05/mt6575-flashing-tutorial.html o en el famoso foro ruso pero no hay forma, el Flash Tool da un error 8038. Previo a esto he instalado los famosos drivers USB VCOM Driver pero también los del propio Lenovo LenovoUsbDriver_1.0.1.

      He probado con varias versiones, entre ellas las bajadas de movilesdualsim y las del propio foro ruso aptas para el Lenovo P770 y su MT6577 pero falla. he probado en otro PC pero falla. Ambos Windows 7. En el trabajo tengo un XP pero no creo que este sea el motivo. he probado en diferentes entradas USB y todas directas. Y no hay forma de rootearlo. Actualmente tengo un Alcatel 918D que rootee y cargue ROOM según instrucciones del foro y tiene un proceso similar pero con el Lenovo P770 nada de nada. Estoy atascado en este primer paso ya que la idea es cargarlo luego una ROM. Praa hacer el rooteo uso el Flash Tool, el archivo de imagen llamado recovery_P770 y el MT6577_Android_scatter_emmc.

      Cualquier sugerencia se agradece. Adjunto algunos pantallazos.



      Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)

      Espero atentamente vuestra ayuda. Muchas gracias.
       

      Adjuntos:

    • jimymoto

      jimymoto Simdualero de Diamante

        7.931
        32
        7 Nov 2012
        navarra

        Hola,

        Yo no tengo ese mismo movil pero eso que dices que no tiene que ver el tipo de windows...yo con el 7 fue imposible hacer root pero en xp lo consegui a la primera,pero esto solo es una experiencia personal y quizas no tenga nada que ver con eso.

        Has probado este metodo?? http://www.movilesdualsim.com/foro/threads/27962-MtkDroidTools-by-Rua1 si no recuerdo mal creo que @pauetepauete hizo root a un Lenovo con este metodo.

        Suerte!!
         
        Última edición por un moderador: 28 Sep 2013
      • txaolin

        txaolin _Super Txaos!!!_ Simdualero de Diamante

          4.105
          352
          31 May 2010
          Siberia Gasteiz

          +1 eso tiene toda la pinta de ser por el WIN7 ,ami con mi antiguo Lenovo me paso mas de lo mismo,lo hice con xp y ala primer me salio perfecto.

          saludos
           
          Última edición por un moderador: 30 Dic 2013
        • GAYAFON

          GAYAFON ANDA... ALEGRAME EL DIA!!! Super Moderador

          • MDS Team
          • Com. Manager MDS
          Es que creo que en windows 7 se hace todo como administrador (si es que no lo tienes configurado asi). Yo el THL le flasee el recovery con el win 7 y todo me salió a la primera. Lo reconoció, instalé el vcom, sin la pirula de la bateria y flasee... (claro que yo tengo todos mis windows como administrador...)
           
        • pauete

          pauete Simdualero de Diamante

          • Veteran@
          9.189
          1.287
          12 May 2010
          @JonJon, prueba de quitar y poner la batería justo cuando la barra en rojo llegue al 100%.

          En Options tienes marcados USB Mode y DA Download?

          Otra opción sería probar con el Preloader y el DSP_BL dentro de la carpeta, junto al scatter y el recovery (los puedes coger de algún firmware del P770)
           
          Última edición por un moderador: 28 Sep 2013
        • Jon

          Jon Simdualero de Bronce

            20
            0
            18 Sep 2011
            Hola nuevamente, he probado casi todo lo que habéis dicho, tenía su lógica pero nada de nada. Ni con el XP tampoco. También he probado la herramienta que mencionais MtkDroidTools pero esta no detecta el móvil siquiera.

            Me queda por probar algo que ya quise hacerlo pero que no pude por no disponer de los ficheros Preloader y el DSP_BL. Pauete, pones que lo puedo coger de algún fimrware pero la verdad que tampoco he podido descargarme ninguno ¿?. He bajado la ROM de Needrom por si estaban ahi pero nada, he mirado en mi teléfono por si podía sacarlo de ahí y nada.

            En la web de Needrom esta muy clarito el tema como podéis ver en este buen tutorial pero luego nada de nada :
            Enlace roto eliminado De hecho te aparece como hacer el ROM entero o sólo del recovery IMage que es lo que yo estoy intentando pero vamos que si cargo la ROM entera igualmente válido siempre que deje hacerlo del Flash Tool sin ser ROM previamente. De todas formas tampoco puedo porque no están la retaila de ficheros que te pide, entre ellos el Preloader y el DSP_BL. En el las imagenes del tutorial para hacer sólo el flash del recovery también viene los dis ficheros sin su path correspondiente, es decir, en rojo pero por otro lado parece que más abajo indica que aunque no este el path puesto deben existir en la carpeta o algo por el estilo ¿? :

            Note that, even though it isn't mandatory to select it on the list of images to flash, preloader file must be present in the same folder as the other partition(s) that you want to flash, or else phone will not be able to enter into download mode.

            Pero si eso debe de ser asi ¿porque no están por ningún sitio esos ficheros? ¿Porque en el foro ruso tampoco dice nada de ellos? ¿porque cuanod te bajas del foro ruso y de esta misma web u otras todo el KIT de drivers, Flash Tools, etc NUNCA existen esos ficheros?. Muy raro, si no aparecen es que no hace falta y algo más pasa.

            Por cierto, he preparado un PC con Windows XP sólo para esto y el error no varia, es exactamente el mismo, el 8038. ¿Que puedo hacer? Ufff como esto siga asi me lo quito....

            Saludos.
             
            Última edición por un moderador: 9 Jul 2016
          • pauete

            pauete Simdualero de Diamante

            • Veteran@
            9.189
            1.287
            12 May 2010
            Casi siempre es tema de drivers, @JonJon
            Te pongo unos videos q hicimos @zoyBzoyB y yo mismo por si te sirven de orientación:
            http://www.movilesdualsim.com/foro/...-Android-dualSIM?p=83943&viewfull=1#post83943

            En el foro ruso verás que sí hay firmwares y otros enlaces y explicaciones: http://forum.china-iphone.ru/lenovo...4gb-4-5-3500mah-t23583.html?hilit=lenovo p770
            Usa Google Chrome para traducir

            De firms oficiales podrás copias el Preleoader y el DSP (son una carpeta que contienen un conjunto de .img).
             
            Última edición por un moderador: 28 Sep 2013
          • pauete

            pauete Simdualero de Diamante

            • Veteran@
            9.189
            1.287
            12 May 2010
            Y otra opción que se me ocurre, si no tienes el Preloader y DSP, es que en Flash Tool mires en "Options" y desmarques el "USB Mode" y "DA Download".
            Y en cambio tengas asignado algún puerto en "COM Port" (en tu caso veo en los pantallazos q se instalaron los drivers en el "COM 5").
            Aprietas "Download", desconectas el cable del puerto y cuando empiece la cuenta atrás en la barra inferior, entonces vuelves a conectar el móvil al USB.
             
          • Jon

            Jon Simdualero de Bronce

              20
              0
              18 Sep 2011
              Hola Pauete y cía, gracias de antemano por vuestras respuestas. De momento no he podido volver a probar nada pero si probé con varios drivers del tipo USB VCOM Driver que descargue de diferentes sitios (foro ruso, movilesdualsim, otros tantos, etc) y verifique que tenian diferentes fechas para tener la certeza que eran diferentes. Probé con varias versiones del Flash Tool descargadas de esos mismos foros y siempre los errores mencionados. Lo probé todo en XP y Win7. Volveré al ataque este fin de semana con lo que me comentais pero el asunto se complica.

              Si pedi este móvil a Beewip era porque un tal Asturshaker en respuesta a un tal ZoyB contesto que en Beewip le habian confirmado que se lo mandaban en Español con lo que no hay duda que para ello habian tenido que hacer el root y cargar una ROM o aunque luego lo dejen "capado" de alguna forma por lo menos lo dejaban en Español y listo para funcinar con todo sin problemas pero a mi me ha llegado el móvil tal cual de fábrica, perfecto Chino. Voy a mandarles otro correo a Beewip con este tema para ver que me dicen, de momento puedo devolverlo algo que me daría bastante pena.

              Dejo la respuesta de Asturshaker a ZoyB sacado del foro, lo podeis ver en http://www.movilesdualsim.com/foro/threads/21880-Lenovo-p770

              ZoyB Dice --> Cita Iniciado por zoyB Ver Mensaje
              Te han dicho que te lo mandan con el idioma español?
              Puedes poner la tienda donde lo has comprado?

              Asturshaker contesta --> Lo he comprado en beewip, y me han confirmado que me lo mandan en español. Ya os daré mas detalles cuando lo reciba.
               
              Última edición por un moderador: 30 Dic 2013
            • Jon

              Jon Simdualero de Bronce

                20
                0
                18 Sep 2011

                Hola, he probado lo que me comentas pero si intento ponerle el puerto com a mano da un error en cuanto le das al downloader y no deja hacer nada más y aparece un error que indica que no detecta la conexión ene l puerto pero por ejemplo si lo ponemos en el modo automatico si la detecta porque como podemos ver ene l pantallazo adjunto te dice que es el puerto 9 o al que le conecte, vamos, que lo detecta fijo.
                He probado con todos y cada uno de los puertos del PC y nada, el mítico error 8038. También he probado a modificar el valor de BAUDRATE y hacerlo coincidir con el que poner en el admin de dispositivos si te pones en el puerto COM. Y nada de nada. De todos modos si dejas seleccionada la opción del USB MODE si que detecta el puerto, eso está claro porque te aparece en la parte inferior del Flash Tool y te dice cual es.

                Lo que si me he fijado es que al conectar el Lenovo P770 aotras USB del PC aparece el clasico mensaje de que windows ha encontrado hardware nuevo y al final dice "NO se pudo instalar software de controlador de dispositivo". Tengo instalado el ejecutable del Lenovo driver además de los USB VCOM Driver, por si sirve de ayuda. En cuanto a los USB VCOM Driver he probado con dos de diferentes fechas pero nada. Os mando pantallazo de la versión de los USB VCOM Driver y de todo lo demás. Muchas gracias!! Saludos

                LenovoP770 root4. LenovoP770 root5. LenovoP770 root6. LenovoP770 root7.
                 
              • pauete

                pauete Simdualero de Diamante

                • Veteran@
                9.189
                1.287
                12 May 2010
                Joder, qué odisea... No sé qué más podrías probar.

                Sin duda los drivers están bien instalados porque si no no llegaría a hacer la primera carga en rojo.

                Yo me había encontrado a veces con qué la versión de Windows podía ser determinante, así como si era de 32 o 64b.. pero en realidad si los drivers están bien, esto último no debería ser determinante.

                Probaste con MTKDroidTools? En ese caso los drivers a instalar son los ADB o "MyHTC" en Adminis.de dispositivos/Buscar en Equipo/Elegir de una lista de controladores compatibles.
                Seguramente deberías desintalar antes manualmente los VCOM.
                Una vez instalados los ADB, el MTKDroidTools te reconocería el móvil y te dejaría rootearlo con el botón SuperUser.

                mtkdroid.

                Creo que SnapPea también instalaba esos drivers.
                 
                Última edición: 4 Abr 2013
              • ptu2221

                ptu2221 Simdualero de Bronce

                  33
                  0
                  28 Mar 2013
                  Despues de pasar un mal rato de narices ... ya que tenia el movil como un ladrillo, al entrar en constantes ciclos de que me reconoce y no me reconoce el dichoso driver com que aparece y desaparece, pruebo a conectarlo con batería al ordenador (tengo w7) y le instalo el Lenovo Adb que me dice. Una vez hecho esto le paso el flash tools y me aparecía y desaparecía el driver que necesita para poder ejecutarse pero voila, llega el momento y me deja actualizarlo ... total que lo he conseguido. Espero que tu tb lo hagas. Pd.: yo tb tenía un HTC instalado de antes en el ordenador.
                   
                Verificación:
                Borrador guardado Borrador eliminado

                Compartir esta página

                Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.