Pulsa aquí para quitar la publicidad.

Problema con los backup con TWRP! Error al restaurar?

Tema en 'Lenovo A820 MTK6589' iniciado por cron0sARSR, 5 May 2013.

  1. cron0sARSR

    cron0sARSR Simdualero de Platino

      333
      1
      2 Abr 2013
      in heaven
      Hola, estoy intentando usar TWRP 2.4.4.0 para crear una copia de seguridad de todo el sistema android (como si fuera una ISO).

      Cuando voy a crear la copia de seguridad marco todos los checkbox siguientes (o sea, todos los checkbox que me salen, no hay más a parte de estos):

      - System (600mb)
      - data (200mb)
      - boot (6mb)
      - recovery (6mb)
      - cache (16mb)
      - uboot (0mb)
      - nvram (5mb)

      la copia de seguridad se crea correctamente en la memoria SD.

      el problema viene cuando voy a restaurar.

      cuando voy a restaurar, para la copia que hice antes, me aparecen estos checkbox (los marco todos):



      Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)

      - system
      - data
      - boot
      - cache
      - uboot
      - nvram

      como podéis ver, el recovery no me sale. Supongo que es normal porque imagino que es la partición o sección de memoria donde están los datos del mismo TWRP y por eso no se puede grabar encima.

      El problema que tengo es que cuando voy a restaurar, al finalizar la restauración me dice "failed". Sin embargo, al reiniciar el teléfono parece que se ha restaurado bien y no soy capaz de ver ningún fallo en el sistema.

      La pregunta es, ¿por qué me sale failed? y también: ¿se ha restaurado todo bien realmente? como hago que no me salga failed?

      gracias y un saludo
       
    • cron0sARSR

      cron0sARSR Simdualero de Platino

        333
        1
        2 Abr 2013
        in heaven
        creo que me salía failed porque había marcado la casilla del recovery durante el backup. como no se ha podido restaurar porque en ese momento estoy usando el programa pues por eso me sale failed. pues no.

        he hecho la prueba de crear una nueva backup sin marcar la casilla recovery y al restaurar, esta vez, me sale failed otra vez. Así que imagino que este no era el motivo del fallo.

        Una pregunta más: ¿este backup puede ser volcado con otro programa que no sea TWRP? si es así cual? puedo volcar la iso desde flash tools por ejemplo? imagino que con el sistema operativo funcionado será imposible...

        gracias y un saludo
         
      • cron0sARSR

        cron0sARSR Simdualero de Platino

          333
          1
          2 Abr 2013
          in heaven
          voy a hacer otra prueba desmarcando la casilla nvram y marcando todas las demás a ver qué pasa....

          si alguien me puede explicar qué es cada cosa le estaría agradecido:

          - System (600mb) ==> sistema operativo completo con applicaciones de fábrica y que está en la parte no accesible de la memoria interna?
          - data (200mb) ==> applicaciones instaladas por mi en la parte de la memoria interna visible donde puedo instalar app?
          - boot (6mb) ==> ni idea
          - recovery (6mb) ==> donde va instalado el TWRP (como si fuera un sector de arranque donde puedes ejecutar ese programa solo sin la ayuda del sistema operativo y de forma autónoma)
          - cache (16mb) ==> ni idea
          - uboot (0mb) ==> ni idea
          - nvram (5mb) ==> ni idea, algo de la memoria ram?
           
        • cron0sARSR

          cron0sARSR Simdualero de Platino

            333
            1
            2 Abr 2013
            in heaven
            bueno, parece que desmarcando la opción de nvram ya no me sale el dichoso error. así que esta podría ser una solución (creo).

            igualmente, si alguien me puede responder a lo que preguntaba se agradece

            posteo todo el proceso por si a alguien más le sirve.

            un saludo
             
          • centuria

            centuria Simdualero de Platino

            • Veteran@
            517
            48
            11 Oct 2012
            gracias por el curro que también te pegas.
            Pero estoy temiendo que me llegue el móvil y luego ponerme a hacer todas estas historias.

            saludos.
             
          • cron0sARSR

            cron0sARSR Simdualero de Platino

              333
              1
              2 Abr 2013
              in heaven
              no te compliques la vida, no necesitas hacer todo esto.... si te va bien que esté en inglés no tienes que hacer nada, solo empezar a disfrutar del teléfono. Solo necesitas hacer inventos si quieres tener permisos root, instalar el recovery o cargar ROMs cocinadas para, por ejemplo, tenerlo todo en castellano. si te va bien en que esté inglés y no te molestan las app chinas que vienen de fábrica puedes hacer update siempre desde el mismo teléfono.

              un saludo
               
            • sATELITE

              sATELITE Simdualero de Diamante

              • Veteran@
              5.140
              10.028
              29 Abr 2013
              Zaragoza
              Boot, Nvram y recovery desmárcalos. Marca sólo System y Data. Cache como tu quieras, pero es un poco inservible.

              A mí, personalmente, los backups con recovery me han dado la lata. Yo prefiero Titanium Backup (por cierto,es un deinstalador bastante competente, casi no deja rastros).

              En ocasiones, la restauración tiene algún fallito. Yo lo he solucionado, reinstalando manualmente SuperSU o Super User (el que tu prefieras), actualizando los binarios y configurándolo para que otorgue los permisos automáticamente ( el otorgamiento de permisos manual agota el tiempo de espera muchas veces). Reinicia y a funcionar.
               
            • cron0sARSR

              cron0sARSR Simdualero de Platino

                333
                1
                2 Abr 2013
                in heaven
                Gracias por la información.

                igualmente, después de usar TWRP y marcar solo system y data, al restaurar, me vuelve a dar error. Luego reinicio y parece que funciona.

                Sabes a qué puede ser debido??

                he intentando usar titanium backup y solo veo que se pueden hacer backups de las aplicaciones sueltas, no de todo el sistema. me podrías indicar como se hace un backup completo con titanium????

                gracias y un saludo!!!
                 
              • cron0sARSR

                cron0sARSR Simdualero de Platino

                  333
                  1
                  2 Abr 2013
                  in heaven
                  a ver si es problema del TWRP.... he visto esto en la web oficial (yo uso la 2.4.4.0):

                  What's new in 2.5.0.0:

                  Special Note: If you are running a custom theme, the changes in 2.5.0.0 will likely not be compatible with your theme.

                  • Added scrollable partition lists for mount, backup, restore, wipe, and storage selection
                  • Add new SliderValue GUI element for selecting brightness and screen timeout (thanks to Tassadar)
                  • Re-work AOSP and TWRP code to improve license compatibility between GPL and Apache
                  • Added official theme for 1080x1920 portrait devices (HTC DNA, HTC Butterfly, Oppo Find 5, Sony Xperia Z, etc)
                  • Fixed a problem with directory permissions on split archive backups
                  • Fixed a problem with md5 verification of backups
                  • Added a search function to libtar (thanks to kokotas)
                  • Improve handling of XML errors (fix permissions)
                  • Fixed handling of subpartitions
                  • Improvements to recovery.fstab flags
                  • Fixed a problem with decryption not being able to locate the decryption key in some situations
                   
                • cron0sARSR

                  cron0sARSR Simdualero de Platino

                    333
                    1
                    2 Abr 2013
                    in heaven
                    a ver si alguien se enrolla y saca la versión instalable con flash tools para la 2.5!
                     
                  • sATELITE

                    sATELITE Simdualero de Diamante

                    • Veteran@
                    5.140
                    10.028
                    29 Abr 2013
                    Zaragoza

                    Pues en el Titanium tienes opción de marcar que haga copias por lotes, sólo de sistema, de apps instaladas, añadir data aparte, incrementales............

                    Y seguramente el TWRP de algún problemilla, a mi me lo daba en mi Blade.

                    Dentro del recovery, intenta buscar una opción que diga más o menos "Toggle sign/verification" y que quede deshabilitada. En ocasiones, al re/instalar roms o backups busca archivos de verificación y se vuelve majara porque un backup no lo tiene.
                     
                  • maple

                    maple Simdualero de Diamante

                    • Veteran@
                    8.404
                    15.764
                    6 Feb 2011
                    Granada
                    A mi los backup echos con ese recovery no me da problemas.
                    Prueba a instalar otra vez el recovery. Descargalo de otro sitio a ver.

                    Otra cosilla, Titanium tiene una opción para crear un zip, para cargarlo desde recovery. Te hace una copia completa.

                    Saludos

                    Enviado desde mi Lenovo A820 usando Tapatalk 2
                     
                  Verificación:
                  Borrador guardado Borrador eliminado

                  Compartir esta página

                  Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.