Pulsa aquí para quitar la publicidad.

Tutorial: posible arreglo para los problemas con el 3G

Tema en 'B94M - Miz Z1 MTK6589' iniciado por titooo, 13 Abr 2013.

Tags:
  1. titooo

    titooo Simdualero de Platino

      257
      1
      14 Oct 2012
      IMPORTANTE:
      Está escrito en un inglés un tanto extraño y no consigo entender si es sólo para solucionar el problema que tienen con el 3G los usuarios chinos de la compañía Unicom o si también servirá para los usuarios el foro que tienen problemas con el 3G. Pero por si acaso aquí os lo dejo por si alguien se atreve a probarlo:
      Regístrate para ver este contenido. Es gratis!


      sacado de http://www.needrom.com/mobile/star-b94mb943/



      Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)


      ACTUALIZACIÓN:
      Algunos compañeros que tienen un otros modelos con mtk6589 aseguran haber podido solucionar sus problemas con este método:
      SOLUCION AL ERROR 3G (Gracias allev ) :
      http://www.movilesdualsim.com/foro/...tar-S5-(flashear-root-recovery-fix-gps-y-3G-)
       
      Última edición por un moderador: 31 Mar 2015
    • Chamlion

      Chamlion Simdualero de Platino

        489
        36
        25 Mar 2013
        Valencia
        Según he leído creo que sí, solo es para Unicom.
        De todas formas si a alguien no le va la red 3G y ha probado de todo y no lo hace funcionar y se atreve a probarlo...
         
      • titooo

        titooo Simdualero de Platino

          257
          1
          14 Oct 2012
          Otra manera de solucionar los problemas de software relativos al 3g o la cobertura es averiguar cual es el archivo que se encarga de ese tema, coger el de un terminal que no tenga ese problema y usarlo en nuestro caso.
          Esta misma mañana por ejemplo he cogido las carpetas /system/app, system/framework y system/etc/permissions tanto del Lenovo A820 y ZTE V987, las metí en un zip para flashearlas y tras hacer wipe cache y dalvik cache en ambos casos funcionaba. Eso fue casi como usar las roms de esos dispositivos en el Star B943 :smile: Digo casi porque los drivers no los copie, pero seguro que se puede ir más allá y si los problemas de 3g y cobertura son de software seguro que se pueden solucionar.
           
        • Chamlion

          Chamlion Simdualero de Platino

            489
            36
            25 Mar 2013
            Valencia
            Pues ojala, el caso sería encontrar donde está el software que hace funcionar el 3G o algo así no?
            Yo en mi antiguo Xperia U encontraba problemas parecidos con el modo de bateria extendida, que desconectaba el 3G para ahorrar batería, y en ocasiones el 3G se paraba sin motivo aparente. Lo mismo pasó cuando le metí el CM9, que en opciones no tiene la opción de modo ahorro en la batería, pero como si tuviera algo en el software que hacía desconectar la red tambien a veces, tal vez tengan algo que haga que se desconecte el 3G en un intento de ahorrar batería?
             
          • Chamlion

            Chamlion Simdualero de Platino

              489
              36
              25 Mar 2013
              Valencia
              Yo sigo teniendo problemas con el 3G/cobertura/micrófono, al rato de estar hablando por teléfono dejan de escucharme, yo a ellos si les escucho pero ellos a mí no
               
            • veradg

              veradg Simdualero de Plata

                90
                0
                18 Feb 2013
                veradg
                Yo tengo el mismo problema, salvando lo de 3G que nunca me va a funcionar donde vivo por ahora. La solucion para el microfono sera cambiarlo directamente?
                 
              • titooo

                titooo Simdualero de Platino

                  257
                  1
                  14 Oct 2012
                  Los que tenéis problemas con el tema ese de las llamadas. Podriaís decirme que versión de banda base y fecha os aparece cuando váis a Ajustes, Información del teléfono?

                  Por casualidad es la siguiente coincidiendo en absolutamente todos los números, fecha y hora: MOLY.WR8.W1248.MD.WG.MP.V2.P1, 2013/02/27 23:29

                  Googleando un poco el nombre de esa banda base veo usuarios con otros teléfonos que se quejan de lo mismo. Si sólo es problema de la banda base creo que estoy muy cerquita de dar con la solución :smile:
                   
                • veradg

                  veradg Simdualero de Plata

                    90
                    0
                    18 Feb 2013
                    veradg
                    DSC02383.
                     
                  • titooo

                    titooo Simdualero de Platino

                      257
                      1
                      14 Oct 2012
                      El mismo que tenía yo y con la misma fecha además. Yo no sé si mi móvil también tendrá ese problema porque nunca he metido una sim en el, jejeje.

                      -Si quieres prueba a descargar esto https://www.dropbox.com/s/khx60t8c8tsuar2/modem.zip?m
                      -Descomprime el zip y te quedará un archivo llamado modem.img.
                      -Pon el teléfono en modo avión.
                      -En el móvil con root Browser o root Explorer renombra el modem.img que está en /system/etc/firmware a modem.bak (un backup vamos).
                      -El modem.img que te has bajado metelo con root Browser o root Explorer en /system/etc/firmware y ponle permisos RW-R--R-- (o lo que es lo mismo 644).
                      -Reinicia y ahora al ir a ajustes e inicio deberías tener una banda base terminada en V7 y con fecha de finales de Marzo (sacada de una rom 4.2 del Zopo ZP800H).
                      -Prueba a ver si sigues teniendo los problemas con las llamadas o si ya va bien.

                      A ver si hay suerte :smile:
                       
                    • veradg

                      veradg Simdualero de Plata

                        90
                        0
                        18 Feb 2013
                        veradg
                        Ya probaste alguna vez esto que indicas?. Voy a probarlo y te comento. De todas formas no estoy teniendo demasiados problemas con eso ya que solo uso 2G porque evidentemente este cel no soporta el ·G en Argentina. Lo que mas quisiera solucionar es el tema del microfono. Hice los ajustes desde ingenieria y algo mejoro, pero al final de reclamar varias veces al vendedor chino quedo en que me enviaba un microfono para cambiarlo directamente y ver si es la solucion definitiva.
                         
                      • titooo

                        titooo Simdualero de Platino

                          257
                          1
                          14 Oct 2012
                          No no lo probé porque no tengo ninguna SIM para meter en el teléfono, por tanto no sé ni si mi teléfono tiene ese problema (el teléfono que uso es un Note 2 que tiene la microsim).

                          Obviamente probar todo tiene sus riesgos, yo simplemente dejo posibles soluciones para quien quiera probar :smile:
                           
                        • veradg

                          veradg Simdualero de Plata

                            90
                            0
                            18 Feb 2013
                            veradg
                            pero esto no implicaria ningun riesgo si hago backup del modem.img original no?
                             
                          Verificación:
                          Borrador guardado Borrador eliminado

                          Compartir esta página

                          Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.