Conflicto en Android 2.3.5. entre APN y com.android.phone

  • Iniciador del tema elena_nito_feliz
  • Fecha de inicio
E

elena_nito_feliz

#1
Tengo un móvil con 2.3.5. (la rom original, y he probado con dos rom más). Es un HD7+ (de los de procesador 6573).

El tema es que las rom reconocen la compañía móvil de la SIM y configuran la automáticamente la APN. En mi caso tengo Pepephone , que funciona con la red de Vodafone . El móvil, al reconocer la red, pone él solito los parámetros de la APN de Vodafone , pero que obviamente tengo que cambiar por las de mi compañía para que funcione.

La faena es que cuando cambias los parámetros de la APN (cuando los modificas, o añades otra APN, o eliminas las que hay y pones una nueva) funciona perfectamente sólo hasta que se apaga la pantalla. A partir de ese momento, parece ser que el com.android.phone hace un "Force Closed" (en realidad no aparece ningún aviso hasta que das a "reiniciar" y aparece el mensajito) y no sale de él hasta que apagas el móvil y vuelves a encenderlo. O sea, que te quedas incomunicao: no funcionan las llamadas de ninguna de las dos sim, ni los datos.

Consulta: por favor, podrías decirme alguien qué archivo debo cambiar de la rom para modificar las APN predefinidas/eliminarlas, o copiar de otra rom? O qué puedo hacer?

Gracias de antemano.

Un saludo

EDITO: Si con el explorador puedo entrar y sustituir algún archivo, mejor que mejor...
 
E

elena_nito_feliz

#2
Bueno, por si a alguien le pasa lo mismo, sólo decir que a pesar de enredar todo lo que he sabido y más, no he sido capaz de solucionarlo. Me he pasado a una rom 2.3.4, que aunque tenga más consumo de batería, al menos funciona...
 

PureMod

Simdualero de Diamante
31 Ago 2010
2.873
1.032
3.789
Android World
#3
Puede ser que este mal los permisos de la apk de phone. A veces pasa.

Saludos!


Enviado desde mi manzana mordida usando tapatalk.
 

nicolau88

Simdualero de Bronce
6 Ene 2012
19
0
436
#4
Buenas
A mi me para algo parecido. Tengo tambien el HD7+ y pepephone en la SIM1 para los datos. La cuestion es que no logro que se conecte a internet.
He puesto el APN de pepephone : gprsmov.pepephone .com y la itinerancia activa. Y no se conecta. Me sale la H y las flechas, pero solo parpadea la de enviar datos, la de recibir no. ( en ocasiones cuando lo acabo de encender funciona bien durante unos 30 segundos, despues deja de recibir datos.
he probado con varias tarjetas de diferentes operadores y en todos se conecta directo al 3g y va perfecto.

Que puedo haces?
Espero me puedas ayudar.
Muchas gracias de antemano.

Ya no se que hacer.