Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.


No verás más estos anuncios al registrarte. Anímate, es gratis, rápido y sin spam!

Conflicto en Android 2.3.5. entre APN y com.android.phone

Tema en 'Móviles Chinos sin Android' iniciado por elena_nito_feliz, 14 Ene 2012.

  1. elena_nito_feliz

    elena_nito_feliz Invitado

      Calificaciones:
      +0
      Tengo un móvil con 2.3.5. (la rom original, y he probado con dos rom más). Es un HD7+ (de los de procesador 6573).

      El tema es que las rom reconocen la compañía móvil de la SIM y configuran la automáticamente la APN. En mi caso tengo Pepephone, que funciona con la red de Vodafone. El móvil, al reconocer la red, pone él solito los parámetros de la APN de Vodafone, pero que obviamente tengo que cambiar por las de mi compañía para que funcione.
      Doogee Aliexpress Ofertas
      Al registrarte dejarás de ver este anuncio. Anímate, es gratis, rápido y sin PUBLICIDAD!

      La faena es que cuando cambias los parámetros de la APN (cuando los modificas, o añades otra APN, o eliminas las que hay y pones una nueva) funciona perfectamente sólo hasta que se apaga la pantalla. A partir de ese momento, parece ser que el com.android.phone hace un "Force Closed" (en realidad no aparece ningún aviso hasta que das a "reiniciar" y aparece el mensajito) y no sale de él hasta que apagas el móvil y vuelves a encenderlo. O sea, que te quedas incomunicao: no funcionan las llamadas de ninguna de las dos sim, ni los datos.

      Consulta: por favor, podrías decirme alguien qué archivo debo cambiar de la rom para modificar las APN predefinidas/eliminarlas, o copiar de otra rom? O qué puedo hacer?

      Gracias de antemano.

      Un saludo

      EDITO: Si con el explorador puedo entrar y sustituir algún archivo, mejor que mejor...
       
    • elena_nito_feliz

      elena_nito_feliz Invitado

        Calificaciones:
        +0
        Bueno, por si a alguien le pasa lo mismo, sólo decir que a pesar de enredar todo lo que he sabido y más, no he sido capaz de solucionarlo. Me he pasado a una rom 2.3.4, que aunque tenga más consumo de batería, al menos funciona...
         
      • PureMod

        PureMod Simdualero de Diamante

        • Veteran@
        31 Ago 2010
        Android World
        Calificaciones:
        +1.075
        Puede ser que este mal los permisos de la apk de phone. A veces pasa.

        Saludos!


        Enviado desde mi manzana mordida usando tapatalk.
         
      • nicolau88

        nicolau88 Simdualero de Bronce

          6 Ene 2012
          Calificaciones:
          +0
          Buenas
          A mi me para algo parecido. Tengo tambien el HD7+ y pepephone en la SIM1 para los datos. La cuestion es que no logro que se conecte a internet.
          He puesto el APN de pepephone : gprsmov.pepephone.com y la itinerancia activa. Y no se conecta. Me sale la H y las flechas, pero solo parpadea la de enviar datos, la de recibir no. ( en ocasiones cuando lo acabo de encender funciona bien durante unos 30 segundos, despues deja de recibir datos.
          he probado con varias tarjetas de diferentes operadores y en todos se conecta directo al 3g y va perfecto.

          Que puedo haces?
          Espero me puedas ayudar.
          Muchas gracias de antemano.

          Ya no se que hacer.
           
        Verificación:
        Borrador guardado Borrador eliminado