Dudas/Problemillas con el Link2SD y la partición secundaria

zehcnas

Simdualero de Plata
6 Mar 2012
54
2
589
#1
Hola chic@s,

Tengo un problemilla con el Link2SD y la partición secundaria de la tajeta SD.
No sé si se ha tratado antes o no, pero no he encontrado nada :(
Según este post de @chaskaman, creo que tengo todo correcto.

Os cuento:
- tengo partición de 1 Gb para aplis en la SD.
- tengo el link2SD, que al arrancar la primera vez monta la partición y, tras reiniciar, crea el enlace correspondiente. Marqué la casilla de enlazar automáticamente después de instalar cada aplicación.
- cuando instalo/restauro una aplicación, inmediatamente después el link2sd la enlaza a la SD (o eso pone en la barra de notificaciones) y me aparece como "Enlazado -> Tarjeta SD" en rojo.
- en las opciones de enlace, tengo las 3 opciones marcadas (incluida la dalvik-cache).

Hasta aquí, creo, todo bien.


Sin embargo:
- Si me voy a ver el uso de almacenamiento, sólo me muestra que tengo 200/300Mb y unos pocos libres (por lo tanto, de vez en cuando me sale el aviso de que no puedo instalar nada más, porque no hay espacio).
- Si voy al Link2SD me muestra el almacenamiento interno, como el de la partición secundaria de la SD, con datos en ambas.
- Cuando instala algo, parece que guarda archivos (y no pocos) tanto en la memoria interna, como en la partición secundaria (entiendo que sólo debería ocupar espacio en la partición, para no consumir para de la memoria interna, no??).

shot_000001.jpg shot_000002.jpg shot_000003.jpg shot_000004.jpg shot_000005.jpg

La lógica me haría pensar que o bien se usa sólo la partición secundaria o, si lo que realmente se hace es "extender" el almacenamiento interno, se debería usar éste, y cuando se llenara pasar a la partición, pero entonces debería mostrar la suma de los 2 como almacenamiento disponible y no dar error cuando se llenara la memoria interna. No???


Alguien sabe qué puedo estar haciendo mal???

Gracias!!!!

shot_000001.jpg


shot_000002.jpg


shot_000003.jpg


shot_000004.jpg


shot_000005.jpg
 
Última edición por un moderador:

chaskaman

Merodeador
Simdualero de Diamante
11 Ene 2012
3.374
263
2.403
Guarida oculta
#2
La mayor parte de la aplicacion se mueve a la particion secundaria, pero parte de la aplicacion se queda en el telefono.

Lo tienes todo bien instalado y correcto.

En tu 3ª captura (la del Link2SD) se ve que tienes 224MB usados de la segunda particion (la de 1GB del LINK2SD) y 702MB libres.

El uso de LINK2SD no te asegura que puedas instalar 1 millon de aplicaciones, solamente te da "algo mas" de espacio. En las primeras versiones de este programa si que "movia" mas a la 2ª particion, pero habia perdida de datos y otras muchas aplicaciones no funcionaban.

Tienes bien depurada la ROM que usas??? O tienes las aplicaciones de Sistema que venian con el telefono??
 
Última edición:

zehcnas

Simdualero de Plata
6 Mar 2012
54
2
589
#3
Gracias @chaskaman, ahora me queda más claro. Me hacía dudar el hecho de que una vez, en algún tuto de Link2SD, me pareció ver una captura de pantalla en la que se veía lo del almacenamiento de las aplicaciones (vamos a decir interno) con un tamaño de 1Gb (como si sumara el interno y la partición). Igual era algo raro... :sad:

Tienes bien depurada la ROM que usas??? O tienes las aplicaciones de Sistema que venian con el telefono??
Sí, yo creo que sí. Esas capturas son de la ROM de @eduardomo, la 1.2.9, y le había quitado alguna cosilla del sistema también.
Anoche puse la nueva de Hammy para probar, aún no la he tocado mucho, estoy probándola hoy...

Gracias!
 
Última edición por un moderador: