Mejora en la batería con BlueSleepFix

silverius

Simdualero de Platino
2 Ago 2012
925
36
1.060
#1
Otra cosilla interesante que he encontrado en xda-developers. También es genérica para todos los ICS.

Por lo visto hay un problema con Bluesleep. Éste programa es parte del sistema de Bluetooth y sirve para que el teléfono no se quede en reposo (Deep Sleep) si está activado el bluetooth. Pero por lo visto el programa funciona mal y no deja que el movil entre en reposo nunca, incluso si no está activado el Bluetooth.

Pero hay un fix. Yo lo he instalado desde cwm sin ningún problema y si que noto mejoras en la batería, pero ocurre que he cambiado varias cosas a la vez y no se cual es la que ha funcionado. Entonces me gustaría que alguno de vosotros lo probase a ver si nota algo. Previo backup, por favooooor.

Descargamos el archivo http://dl.dropbox.com/u/94438244/bluesleepfix.zip
Desde cwm se instala el zip, no hace falta wipe ni nada de eso, solo instalar.

El hilo del que lo saqué es este: http://forum.xda-developers.com/showthread.php?p=30984775

Ya me comentáis vuestras impresiones.

Saludos
 

sonrip

Simdualero de Plata
28 Ago 2012
59
0
416
#2
Hola me gustaria saber que rom utilizas. yo tengo la vietnamita. Se puede usar este parche en ella?
 

silverius

Simdualero de Platino
2 Ago 2012
925
36
1.060
#3
Pues si... sin problema, pero deberías buscar y quitar ( si la tienes) una línea del build.prop, esta:
Persist.sys.use_dithering = 0

De momento buenos resultados.
Instala CPU spy y verás que indica que el micro tiene 5 estados, el último deep sleep, actualmente a mi me marca sobre el 50% del tiempo en deep sleep.
Si te dice que ese estado nunca se ha utilizado, deberías instalarlo, de lo contrario no.

Lo que no se es si la rom vietnamita lo necesita. Yo uso la oficial bastante modificada...

Saludos

Sent from my ZP100 using Tapatalk 2
 

silverius

Simdualero de Platino
2 Ago 2012
925
36
1.060
#4
Eso si, x si acaso debes hacer backup...
Siempre que se instale algo vía cwm mejor respaldar los datos.

Sent from my ZP100 using Tapatalk 2
 

sonrip

Simdualero de Plata
28 Ago 2012
59
0
416
#5
Ese fichero build.pro donde se encuentra? He instalado el parche en un hace y sin problemas ya os comento lo k ocurre.

Ya esta en system pero la línea esa es igual a 1 en vez de 0. Es lo mismo?

Grax.
 

silverius

Simdualero de Platino
2 Ago 2012
925
36
1.060
#6
Mejor pon un # delante, así lo deshabilitas.

Luego prueba con CPU spy a ver que resultados te da, una buena prueba es abrir en CPU spy, resetear el tiempo y apagar la pantalla durante 15 min. En mi caso el Deep Sleep da 92%

Sent from my ZP100 using Tapatalk 2
 

sonrip

Simdualero de Plata
28 Ago 2012
59
0
416
#7
Lo tengo instalado, pero al quitar la linea de ese fichero me da un error de la cobertura y esta dandolo todo el rato. Antes de instalar el parche el cpu spy me daba un 100% en 1000mhz, aplico el parche y me aparece el deep sleep. Ya os comento como me va, pero he tenido q poner otra vez la linea esa.
 

silverius

Simdualero de Platino
2 Ago 2012
925
36
1.060
#8
Con esa línea yo creo q funcionará igual... o eso creo, pq con valor 1 no he probado.

Y ya si pones el micro en ondemand es la leche. Yo para eso, y mucho mas, uso room toolbox. Aplicación recomendadísima, sustituye a unas cuantas habituales.

Sent from my ZP100 using Tapatalk 2
 

sonrip

Simdualero de Plata
28 Ago 2012
59
0
416
#9
Voy a probarla gracias
 

Ixreb

Simdualero de Oro
8 Sep 2011
130
1
558
#10
me mantendré al loro de este tema, a ver qué tal os funciona. Ahora no tengo tiempo de probar en el mio.
 

Jesu1701

Simdualero de Oro
10 Ago 2012
157
1
458
#11
He comprobado que últimamente la batería me duraba poquito, y he mirado lo del deepsleep y apenas esta un 2% así, con varios programas he comprobado que mi zopo esta siempre al 100% (1ghz), salvo contadas ocasiones que reduce una pizca.

La cosa es que intento instalar este parche desde el recovery y me da error al seleccionar el ZIP .

( Acabo de pensar que, no se que recovery tengo, pero me parece que no es el CWM recovery xD, alguna forma , y archivo, para meterlo sin tener que cambiar la room , tengo ICS).
 

allimite

Simdualero de Bronce
6 Abr 2012
37
1
540
#12
Sospecho que hay un error asumiendo que esto pasa en todos los ICS, el error se produce en Motorola droid X2 ya que el kernel es de gingerbread y no el propio de ICS, ellos mismos lo dicen aquí:

Why did this bug occur?
Normally, an ICS kernel would take care of all of this. But due to us still having a Gingerbread kernel, we still need these binaries.

Saludos