Quantcast

Problema WiFi. MAC 02:00:00:00:00:00

  • CONSULTA 
  • Iniciador del tema calib7
  • Fecha de inicio
C

calib7

Simdualero de Bronce
3 Oct 2020
5
3
38
#1
Hola a todos:

Tratando de rootear mi terminal (un Redmi 4x) he perdido la conectividad WiFi. Ésta se encuentra desactivada y al deslizar el botón de activación en la configuración se vuelve a desconectar sola. Además he visto que la MAC de la WiFi ha cambiado a 02:00:00:00:00:00.

He probado a cambiar el fichero de WCNSS_qcom_cfg.ini de /data/misc/wifi pues he leído en algún foro que esto funciona, pero no hay manera.

¿Alguien puede orientarme?
Gracias en cualquier caso.
 
androidzinho

androidzinho

Friki de la vieja escuela
VIP
12 Jul 2013
13.823
21.326
12.135
Domaio (Pontevedra)
www.movilesdualsim.com
Mi 10T Pro
#3
Lo ideal sería que nos contases como has intentado rootear el móvil y si has hecho alguna cosilla más después.
Si solo te falla eso, es decir, si el baseband está bien (no aparece como"unknown") y si conservas el imei, lo suyo es flashear el archivo persist.img, que encontrarás en la rom para fastboot, vía adb usando el comando:

fastboot flash persist persist.img
 
androidzinho

androidzinho

Friki de la vieja escuela
VIP
12 Jul 2013
13.823
21.326
12.135
Domaio (Pontevedra)
www.movilesdualsim.com
Mi 10T Pro
#5
C

calib7

Simdualero de Bronce
3 Oct 2020
5
3
38
#7
C

calib7

Simdualero de Bronce
3 Oct 2020
5
3
38
#9
Lo ideal sería que nos contases como has intentado rootear el móvil y si has hecho alguna cosilla más después.
Si solo te falla eso, es decir, si el baseband está bien (no aparece como"unknown") y si conservas el imei, lo suyo es flashear el archivo persist.img, que encontrarás en la rom para fastboot, vía adb usando el comando:

fastboot flash persist persist.img
Bufff. Conecté el móvil con un software que descargué (a saber Dios de dónde) y que se suponía que instalaría Magisk. El terminal lo tenía ya con el bootloader desbloqueado, todo bien hasta que pulsando el botón correspondiente de la aplicación para hacer root (era una herramienta con GUI) me dice que ya soy root pero no me dejaba acceder a ficheros de sistema; intentando navegar con el Root Explorer de Speed Software me mostraba error por permisos de acceso, necesitaba ser root. Ahí ya no tenía WiFi.

Finalmente instalé TRWP y SuperS; ahora sí tengo acceso superusuario e intenté una copia del fichero "WCNSS_qcom_cfg.ini" entre las rutas /etc/wifi y /data/misc/wifi; leí en un foro que podría restaurar la configuración WiFi copiando este fichero. No recuerdo cuál era la ruta de origen y la de destino, pero lo hice tal cual indicaban en el foro; creo que /etc/wifi era el origen y la otra el destino.

No sé cómo reconocer el estado del baseband, cuando conecto por adb y activo el terminal en modo debugger me identifica el dispositivo con un indicador y me permite conectarlos una vez le doy permisos desde el teléfono. Tampoco sabría de dónde sacar el archivo persist.img.

Los valores de MEID (que no sé lo que será), IMEI1 e IMEI2 me los muestra correctamente al hacer una solicitud *#06#.

Lo único que he notado visualmente es la pérdida del WiFi e imposibilidad de activarlo (se desactiva solo) y el valor extraño de la MAC, el que comento en el título.
 

¿Qué tecnología no debe faltar en tu próximo móvil?

  • NFC

    Votos: 158 45,3%
  • Carga inalámbrica

    Votos: 124 35,5%
  • Carga ultra rápida

    Votos: 200 57,3%
  • 5G

    Votos: 150 43,0%
  • Al menos 3 cámaras principales

    Votos: 99 28,4%
  • Sensor TOF

    Votos: 60 17,2%
  • Lector de huellas

    Votos: 184 52,7%
  • USB tipo C

    Votos: 189 54,2%
  • Bluetooth

    Votos: 170 48,7%
  • Pantalla flexible

    Votos: 25 7,2%

Miembros conectados

  • ck_lgr
  • jmaqg
  • blanchboy
  • ihesu
  • mecharn
  • otzua
  • Kvothe1979
  • Juan carlos Pérez Coll
  • SIgNIFER
  • ajtharsis
  • xxermolaxx
  • arditurri
  • kiensino
  • terrybogard
  • joseyspain
  • rovimis
  • tecnoadicto
  • pyrumax
  • fjmallen
  • Pebbless1986
... y 37 más.