Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.


No verás más estos anuncios al registrarte. Anímate, es gratis, rápido y sin spam!

ROM Zopo ZP820 en Lenovo A850

Tema en 'ROMs Lenovo A850' iniciado por TorpedoJavi, 14 Nov 2013.

  1. TorpedoJavi

    TorpedoJavi Simdualero de Oro

      1 Nov 2013
      Calificaciones:
      +63
      Bueno, como sabéis estas ROM comparten procesador y chips de modem, y seguramente WIFI.
      Doogee Mix Ofertas
      Al registrarte dejarás de ver este anuncio. Anímate, es gratis, rápido y sin PUBLICIDAD!

      Antes de hacer esto pásate por:
      Salvar tu NVRAM (antes de cualquier FLASHEO de una nueva ROM debes hacerlo sí o sí)
      y por
      Backup ROM e instalación Recovery en inglés A850

      No sigas si no has hecho al menos el de la NVRAM.

      Bueno, seguimos.

      He cogido la ROM china S128 y DIRECTAMENTE le he puesto la carpeta system.img del Zopo ZP820, y he desactivado en el Checksum.ini de la ROM el Checkum Switch (lo he puesto a cero).
      Luego con las Flash Tools:
      - Elijo Firmware Upgrade
      - Conecto el teléfono sin batería, detecta y empieza a escribir
      - Termina (circulo verde) y desconecto
      - Pico en DADL with all y luego pico en Download
      - Conecto el teléfono sin batería, detecta y empieza a escribir.
      - Termina (circulo verde) y desconecto

      ROMS base:
      Enlace roto eliminado
      Enlace roto eliminado

      Cosas que ocurren:
      - Arranca
      - Va muy fluido
      - Las fotos salen muy bien
      - Es muy bonito, mucho colorido, da alegría.
      - Todo en castellano
      - No va el GSM -> Se soluciona y funciona el 3G perfectamente estable.
      - Las llamadas se oyen muy bien y bien altas.
      - No tiene la función de grabar las conversaciones de los Lenovo... (algo básico cuando te acostumbras)
      - Va el GPS, aunque se equivoca en 100 metros al sur (curioso....)
      - No va el WifiBlueTooth -> Sin solución de momento
      - Sin led de notificaciones

      El GSM los solucioné copiando a mano los ficheros de la NVRAM, (no la imagen binaria) a la nvram de la carpeta data y dando permisos de escritura a todos los ficheros de la misma.

      La Wifi y el BT estoy en ello....

      Creo que el problema se debe a que la ROM busca la NVRAM FLASH donde no es, así de simple, ya que el Scatter del Zopo aunque tamibién es un MT6582 es algo diferente.

      Estoy casi seguro que flasheando la ROM entera se arregla, pero... no me atrevo, vaya a ser que el preloader no tire después......

      Vuelvo a la china a probar cosas ;-)

      Adjunto pantallazos y dos fotos con flash (la primera sin luz de techo, no veía nada ni yo, y la segunda con luz)...

      www.pictureshack.us_thumbs_18442_Screenshot_2013_11_14_19_52_00.

      www.pictureshack.us_thumbs_78472_Screenshot_2013_11_14_19_52_59.

      www.pictureshack.us_thumbs_59764_Screenshot_2013_11_14_19_54_58.

      www.pictureshack.us_thumbs_32020_Screenshot_2013_11_14_19_55_32.

      www.pictureshack.us_thumbs_24838_Screenshot_2013_11_14_19_55_48.

      www.pictureshack.us_thumbs_91181_IMG_20131114_195725.

      www.pictureshack.us_thumbs_18473_IMG_20131114_195807.
       
      Última edición por un moderador: 10 Abr 2017
      • Me Gusta Me Gusta x 1
      • Cancerbero13

        Cancerbero13 Morcillateam, tu morcilla tecnologica. Simdualero de Diamante

        • Miembro de Honor
        • Veteran@
        30 Sep 2012
        Entre Aries y Capricornio.
        Calificaciones:
        +19.717
        Que buena pinta, sigue teniendo la banda 900?

        Enviado desde mi Lenovo A850 usando Tapatalk 2
         
      • castrillo

        castrillo Simdualero de Oro

          18 Oct 2013
          Calificaciones:
          +15
          si te sirve de ayuda en forocoches comentan que los "chinos" han sacado un port del ZTE 969 , yo lo intente bajar pero estaba todo en chino y encima tenias que registrarte...
          saludos
           
        • TorpedoJavi

          TorpedoJavi Simdualero de Oro

            1 Nov 2013
            Calificaciones:
            +63
            Eso no lo miré! Ahora estoy apunto de probar el update de zoyB
            --- Comentario doble fusionado, 14 Nov 2013 ---
            zoyB, tu update hace que deje de arrancar el móvil.....

            No sirve :-(
             
            Última edición: 14 Nov 2013
          • corcolero

            corcolero Simdualero de Bronce

              17 Feb 2013
              Calificaciones:
              +0
              Gracias por preocuparte en trastear y conseguir nuevos avances! :up:
               
            • Teseracto

              Teseracto Simdualero de Bronce

                15 Jun 2013
                Calificaciones:
                +1
                Cuando puse esta ROM me dejaba hacer fotos de 8mpx y la cámara iba super rápida, ¿se podrían extraer los "drivers de la cámara" de esta ROM y ponerlos en cualquiera?
                 
              • makareno

                makareno Simdualero de Plata

                  20 Oct 2013
                  Calificaciones:
                  +10
                  Muy bonita es,va la sd?

                  Enviado desde mi Lenovo A850 mediante Tapatalk
                   
                  • Divertido Divertido x 1
                  • isyc

                    isyc Simdualero de Oro

                      11 Nov 2013
                      Calificaciones:
                      +34
                      Joer :smile::smile: tiene una pinta muy buena lastima que no pueda funcionar el Wifi y el BT.
                      Vaya alegria de colores
                      flasheando la ROM entera, se me queda la pantalla en blanco,
                      te lo comento por si te vale de algo
                       
                    • castrillo

                      castrillo Simdualero de Oro

                        18 Oct 2013
                        Calificaciones:
                        +15
                        El GSM los solucioné copiando a mano los ficheros de la NVRAM, (no la imagen binaria) a la nvram de la carpeta data y dando permisos de escritura a todos los ficheros de la misma.

                        puedes esplicar esto mejor? gracias por adelantado
                         
                      • calos

                        calos Simdualero de Bronce

                          22 Nov 2013
                          Calificaciones:
                          +0
                          Torpedojavi puedes subir la carpeta system de esta rom a ver si soluciono fallos.
                          Ahi una del THL w 100s en htcmania tambien puede portarse.
                           
                        • TorpedoJavi

                          TorpedoJavi Simdualero de Oro

                            1 Nov 2013
                            Calificaciones:
                            +63
                            Sí, que como tenía una copia de mi NVRAM, tanto en imagen binaria como en ficheros sueltos comprimidos, los de la carpeta nvram, no tuve más que sobreescribir dichos ficheros y funcionó la telefonía.

                             
                          • TorpedoJavi

                            TorpedoJavi Simdualero de Oro

                              1 Nov 2013
                              Calificaciones:
                              +63
                              La ROM es ésta http://www.needrom.com/mobile/zopo-zp820/

                              ¿Sabes extraer los ficheros la carpeta system?

                              Yo uso linux y uso las ext4 utils compiladas con make para extraerlas.
                              https://android.googlesource.com/platform/system/extras/+/master
                              https://github.com/YuLaw/ext4-utils

                              Si no puedes dímelo y te las subo. ;-)

                               
                            Verificación:
                            Borrador guardado Borrador eliminado