Pulsa aquí para quitar la publicidad.

Consumo de batería. Deep sleep

Tema en 'ZTE v987 MTK6589' iniciado por p82maarj, 5 Sep 2013.

Tags:
  1. p82maarj

    p82maarj Simdualero de Bronce

      15
      0
      30 Ago 2013
      Tengo un v987 hace meses. Al principio (ROM original y ROM bruno 1.0)la batería me llegaba al final del día con un 60% haciendo un uso normal y ahora me llaga justo al final del día.

      No parece tener la batería estropeada porque la descarga es lineal.

      He probado todas las ROMs y las he instalado varias veces cada una (LEWA OS, MUIU, BRUNO, etc).

      Viendo si era de la ROM he vuelto a poner todas totalmente limpias (solo instalando el cpu spy y el battery monitor) y no me consume ninguna ni en modo avion menos de 3%(chequeado con las app battery monitor y battery drain) la hora, cuando al principio le quitaba los datos y el wifi y en toda la noche me consumía como mucho un 2%.

      También he probado a formatear la tarjeta sd y dejarla casi sin fotos ni videos, pero nada.



      Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)

      El cpu spy nunca me pone "deep sleep" mientras que en capturas del cpu spy de otros mtk6589 si lo pone (a mi me pone almenos un 80% del tiempo a 1200mhz).

      Os importa instalar el app cpy spy y decirme que rom teneis y si os entra en deep sleep e instalar también el battery monitor y decirme cual es vuestra descarga mas o menos.

      Muchas gracias a todos!!
      Screenshot_2013-09-05-16-51-15. Screenshot_2013-09-05-16-50-51. Screenshot_2013-09-05-16-50-30.
       
    • kratos69

      kratos69 Simdualero de Plata

        75
        0
        18 Ago 2013
        Spain
        Claramento esto es el kernel. El gobernador está en ondemand o quizás en performance, te recomiendo que dejes el de stock. Bajate la aplicación NO-FRILLS CPU y dime que gobernador te sale!
         
      • p82maarj

        p82maarj Simdualero de Bronce

          15
          0
          30 Ago 2013
          el gobernador es hotplug, que es el por defecto del mtk6589. Gracias!
          Voy a subir las fotos en links para que se vean mas grandes
           
        • kratos69

          kratos69 Simdualero de Plata

            75
            0
            18 Ago 2013
            Spain
            Entonces hay algo poniendo el procesador al máximo todo el tiempo, algo no está funcionando como debiera... algun tweak, algo está poniendo el procesador al máximo.
            Revisa la carpita /etc/init.d/ y dime que archivos hay dentro, si puedes, pasamelos que los vea y te comente!

            Fotos a imgur.com, tanto de Cpu Spy como No-frills cpu!
             
          • p82maarj

            p82maarj Simdualero de Bronce

              15
              0
              30 Ago 2013
              http://imgur.com/icMLbb2
              http://imgur.com/28QLokC
              http://imgur.com/GBLcP2G

              ¿a vosotros el cpu spy os pone deep sleep? Es raro porque he instalado muchas roms y sin instalar ningun programa la batería baja rapidito aunque lo ponga en modo avion y lo deje con la pantalla apagado, más o menos lo que me dice el battery widget un 3%/hora.

              También tengo instalado el recovery y la partición de 2gigas para aplicaciones que aparece en la entrada del manual para el v987... a ver si va a ser eso.

              http://imgur.com/N1IbvJr
              http://imgur.com/icMLbb2
               
            • p82maarj

              p82maarj Simdualero de Bronce

                15
                0
                30 Ago 2013
                Postee ayer las fotos pero no aparece el post...lo estará revisando el administrador.

                He seguido investigando y he sacado una conclusión:
                No importa la Rom que instale que al apagar la pantalla la cpu 0 se pone a 1209mhz, en cambio cuando la enciendo se ven todas las cpus apagadas menos el principal que se pone a 497mhz.

                Lo he descubierto analizando las estadísticas. Si el movil lleva por ejemplo 3:00 (3 min) a 1209 y 1:00 a 497, si con la pantalla encendida voy refrescando las estadísticas el 1209 apenas avanza y el 497 va subiendo. tras un minuto pasan a tener 3:02 a 1209 y 1:58 a 497. Si ahora apago la pantalla durante un minuto, al encenderla y refrecar las estadísticas pone 4:00 a 1209 y 2:00 a 497.

                Parece algo de la gráfica porque he probado todas las Roms que existen limpias, sin nada instalado. He flaseado de nuevo el recovery, he flasheado las particiones...de todo.

                He probado a cambiar el governor a ondemand, pero no apaga los otros 3 nucleos como si hace el hotplug, he probado a cambiar el governor de i/o y nada.

                ¿alguna solución?
                 
              • p82maarj

                p82maarj Simdualero de Bronce

                  15
                  0
                  30 Ago 2013
                  He realizado un perfil con el kernel tuner y el tasker de modo que cuando se apague la pantalla el máximo de la cpu 0 a 497mhz y cuando se encienda el máximo sea 1209mhz y ahora con el cpu spy se me queda el 95% en 497....un paso adelante.
                  Ahora solo me pasa saber porque y si a vosotros os entra en deep sleep.
                  Gracias
                   
                • Ivanymarzzia

                  Ivanymarzzia Simdualero de Platino

                    314
                    40
                    12 Dic 2012
                    Spain
                    Probaste la ROM oficial de ZTE?
                     
                  • kratos69

                    kratos69 Simdualero de Plata

                      75
                      0
                      18 Ago 2013
                      Spain
                      La verdad? Has hecho todo lo posible por solucionarlo. No sé que puede estár yendo mal :S
                       
                    • p82maarj

                      p82maarj Simdualero de Bronce

                        15
                        0
                        30 Ago 2013
                        Si, he probado la última rom oficial e igual... Gracias a todos, seguiré investigando y si encuentro algo os cuento.
                         
                      • p82maarj

                        p82maarj Simdualero de Bronce

                          15
                          0
                          30 Ago 2013
                          Desinstalando el CPU spy y capturando con el cpu frills ya no se queda la cpu a 1209mhz :dizzy:
                          Ahora solo me queda que entre en deep sleep :wink:
                           
                        • kratos69

                          kratos69 Simdualero de Plata

                            75
                            0
                            18 Ago 2013
                            Spain
                            Cuanto menos extraño tu problema! :dizzy:
                            El martes tendré el terminal y ese día te cuento!
                             
                          Verificación:
                          Borrador guardado Borrador eliminado

                          Compartir esta página

                          Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.