Pulsa aquí para quitar la publicidad.

Problema con WiFi OT890D

Tema en 'Alcatel OT-890D' iniciado por shouled, 23 Dic 2011.

Tags:
  1. shouled

    shouled Simdualero de Bronce

      Buenas!

      No sé si a alguien más le haya pasado lo mismo, pero el wifi de mi OT890D (Froyo 2.2.2) no funciona. Detecta las redes pero con baja señal (inclusive si estoy junto al router) y no se conecta de ninguna manera. Ya le he instalado aplicaciones como Wifi Analyzer, Wifi Fixer, etc, pero nada. Sigue sin conectarse. Probé haciendo la actualización con la herramienta que está en la página (http://www.alcatelonetouch.com/global-en/downloads/otu/One Touch Upgrade S 1.4.2 Setup.rar) y nada. No se conecta.

      Lo único que hace es tratar de conectarse... pero al instante dice desconectado. Es como si tuviera algún tipo de problema con al configuración del wifi o algo así. Leyendo en foros encontré que FroYo a veces molesta el wpa_supplicant, pero no sé si ese pueda ser el problema, y de todas formas, no tengo uno que funcione bien como referencia para saber qué hay que modificarle.



      Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)

      ¿Alguien tiene alguna idea de lo que le puede suceder y cómo solucionar esto?

      De antemano, gracias.
       
    • Breakk

      Breakk Simdualero de Diamante

      • Cocinero Android
      • Veteran@
      11.944
      20.220
      31 May 2010
      Hola,yo tengo este movil y el wifi funciona bien. Prueba a abrir tu red wifi y cambiabel nombre tu red para que la busque. Yo tengo 'çnfigurado el router con wpa y es un zyxel. Ta?bien he probado comtrend,thomson y xavi.
      Saludos

      Enviado desde mi Alcatel one touch 890D usando Tapatalk
       
    • shouled

      shouled Simdualero de Bronce

        Gracias por responder, @BreakkBreakk. Intenté lo que me aconsejas, pero es unútil. Intenté con varias redes más, con diferentes tipos de router y nada. ¡Ni siquiera se cuelga de las señales abiertas de los centros comerciales! :S
         
        Última edición por un moderador: 28 Sep 2013
      • Breakk

        Breakk Simdualero de Diamante

        • Cocinero Android
        • Veteran@
        11.944
        20.220
        31 May 2010
        Pues, lo que se me ocurre es que resetees el movil a estado de fabrica pero antes guardate todos tus contactos, sms, apps,etc.

        Tambien puedes intentar actualizar el firmware si el Alcatel update de la opcion. El mio me dice que tengo la última version de firmware pero al mejor el tuyo si que te deja actualizar.

        El enlace de descarga te lo pongo aqui:

        http://www.alcatelonetouch.com/global-en/downloads/otu/One%20Touch%20Upgrade%20S%201.4.2%20Setup.rar

        El driver para que te lo detecte está dentro de la carpeta que crea el mismo programa en la ruta: c, one touch upgrade s1.4.2,usb driver.

        Para que te detecte el movil el programa , cuanto te pida conectarlo, lo conectas apagado y antes de conectar el usb tienes que presionar la tecla de llamada verde y la roja de colgar al mismo tiempo, conectas el usb al pc y acto seguido sueltas ambas teclas. Entonces veras que te carga el driver y por tanto te lo detecta el programa. Acto seguido verá si tienes el firmware ultimo y sino te lo descargará y sin hacer nada mas te actualizará el telefono. No lo desconectes hasta que el programa te lo diga, sino podrias quedarte con un ladrillo.

        Saludos.
         
        Última edición por un moderador: 30 Dic 2013
      • shouled

        shouled Simdualero de Bronce

          @BreakkBreakk, gracias por la respuesta. La verdad eso ya lo intenté, y nada. Sigue igual. Contacté a la gente de Alcatel y me dijeron precisamente eso —que lo actualizara—, pero como el problema persiste me dijeron que los ingenieros de ellos lo iban a revisar (o como quien dice, no tenemos ni idea).

          No sé, se me hace muy raro que con la actualización no funcione. Porque detecta las redes pero con muy baja potencia y tal vez por eso no se conecte a ninguna. :/
           
          Última edición por un moderador: 28 Sep 2013
        • Breakk

          Breakk Simdualero de Diamante

          • Cocinero Android
          • Veteran@
          11.944
          20.220
          31 May 2010
          @shouled,Yo normalmente estoy enfrente del router, pero a veces me bajo al piso de abajo de casa y aunque debil, si que coge la señal del wifi. Es muy raro todo esto que te ocurre.

          ¿Cuando estás delante de tu router que cantidad de señal te da?¿has probado a cambiar el canal de emision del wifi de tu router? A ver si es que estas en el mismo canal que algun vecino y las señales se mezclan y por ello tienes una bajada de señal y no te coge red o se desconecta.

          Prueba a asignar a tu router una ip fija, no DHPC, y mira a ver si te la coge mejor la señal.

          Encuanto a la conexion en redes wifi de la calle, esto es muy relativo, ya que depende de muchos factores a parte de el alcance de recepción que tenga tu smarphone.

          Por cierto, si puedes entra en Ajustes,Acerca de telefono, y dime que version de firmware te aparece que tienes instalada y numero de versión. Yo tengo 2.2.2 y en numero de versión ALPS.10Y.W10.48.MP.JRD.SP.V4. Antes de actualizar tenia otra Version de banda base, pero ahora tengo esta: MAUI.10A.W10.48.MP.V5.F1.P11. El P11 es el que me cambió, antes tenia creo recordar un P04 y la única diferencia que he visto es que se añadió un explorador de archivos que antes no estaba.

          ¿Te han dicho cuando tienen pensado sacar un firmware nuevo o actualizar a la 2.3.? ?

          Saludos.

          PD:

          Para salir de dudas, hay un menu de fábrica (FACTORY MODE) que se accede reiniciando el telefono y pulsando la tecla de volumen - (hacia abajo) y la tecla de encendido, luego sueltas la de encendido roja y te quedas pulsando unos segundos mas la de volumen hacia abajo. Dentro de este menú puedes probar todos los componentes del Alcatel. Hay un apartado para probar el wifi. Para moverte entre el menú se hace con la tecla volumen, seleccionas ITEM TEST. Luego te desplazas hasta WI-FI y la seleccionas con la tecla central cuadrada (la del dibujo de la casa). Entonces lo que hará es buscarte una red wifi y te dirá su nombre y cantidad de señal en dB.

          Como ejemplo, yo estoy ahora mismo delante del router a medio metro y ambos encima de la mesa, la señal que me da es de -46 dBm.
          Para salir del test te desplazas hasta Test Pass y le das con el boton cuadrado.
          Prueba el test y me dices como te ha ido.

          Saludos.
           
          Última edición por un moderador: 30 Dic 2013
        • shouled

          shouled Simdualero de Bronce

            Gracias de nuevo, @breakk .

            La versión de Firmware es la misma que tú tienes. Firmware 2.2.2 Build ALPS.10Y.W10.48.MP.JRD.SP.V4 y Base MAUI.10A.W10.48.MP.V5.F1.P11. El kernel es 2.6.32.9 android-bld@aclgcl-ubnt57 #1 Tue Nov 1 16:14:44 CST 2011.

            Hice la prueba de Factory Mode y al estar cerca al router (+- 1m) me da -50dB, o sea que el problema es por otro lado. Y ya creo saber cuál es.

            En el menú de Factory Mode, en el ítem Version, me dice que la MAC del Wifi es 00:0c:e7:##:##:##, en cambio, si entro a los ajustes de wifi por Android me da un número totalmente diferente: 41:5f:dd:##:##:##. Obviamente, hay algo mal ahí. Supongo que el número de MAC correcto es el primero (el que se ve por Factory Test) y no el que se ve por Android. Lo digo porque al chequear las direcciones MAC en esta página http://www.coffer.com/mac_find/ en la primera me sale que el fabricante es MediaTek Inc, en cambio con la segunda no me sale nada.

            Ahora, el asunto es: ¿cómo puedo cambiar esta dirección en Android para que coincida con la de la programación? Porque, creo yo, si la MAC del dispositivo no es la misma en ambos lados, pues no se va a poder conectar nunca.

            Se agradece toda la colaboración! :smile:

            Edit:

            @BreakkBreakk aún los de Alcatel no me han dicho cuándo van a actualizar el firmware. Eso sí, tan pronto sepa te lo comunico.
             
            Última edición por un moderador: 30 Dic 2013
          • Breakk

            Breakk Simdualero de Diamante

            • Cocinero Android
            • Veteran@
            11.944
            20.220
            31 May 2010
            Cuando tenga un poco de tiempo te miro lo de mi mac. Te comento que yo tengo conectado el router a mi telefono por ip fija. A ver si ahi puede que tengas el problema o con las dns de configuracion que si tienes ip fija en el movil, debes de asignarlas manualmente para que te funcione mejor, tanto la dns1 como la dns2. Tambien debes de poner a mano tanto la puerta de enlace como la mascara subred. Prueba a asignar un ip fija a tu movil y configura todo lo que te he dicho a mano.

            El tema de la mac, puede que te diga en modo fabrica la mac de la targeta wifi tuya del movil y encambio por otro lado te de la mac de la targeta wifi del router (es una suposicion, ya te lo confirmo luego). Si no tienes bien las dns o cualquier chorrada puede que te haga la pirula como te está haciendo.

            Saludos.
             
            Última edición por un moderador: 30 Dic 2013
          • Breakk

            Breakk Simdualero de Diamante

            • Cocinero Android
            • Veteran@
            11.944
            20.220
            31 May 2010
            @shouledshouled, acabo de mirar lo de la mac. A mi tambien me da diferente:

            Wifi Mac: 000cxxxxxxxx

            y la otra:

            BT ADDR: 44axxxxxxxxxx


            Asi que eso no es. Una mac es la de la targeta de red wifi y la otra la del bluetooth creo.

            Esto lo he visto en el menu de Version que comentabas, Y la Mac que pone en Ajustes wifi, menu, avanzado tambien es la BT ADDR.

            Entonces o bien tienes algun programa de busqueda de wifis, claves, etc que te está molestando o bien no está bien configurada la conexion wifi. Prueba a enrrutar el wifi con ip fija como te he comentado antes, poniendo todos los parametros a mano como te he comentado a traves del menu Ajustes wifi, menu, avanzado. Alli pon la puerta de enlace de tu router, una ip fija diferente de la del router, dns 1 y 2, mascara y lo mas importante, configura el router con ip fija y deshabilita el DHCP. Me da la sensacion que en alguno de los dos (router o movil) tienes mal configurado la ip y por ello te hace esto. No puedes tener el DHCP habilitado en el router y tener una ip fija en el movil.

            Saludos.
             
            Última edición por un moderador: 28 Sep 2013
          • shouled

            shouled Simdualero de Bronce

              @breakk , gracias de nuevo.

              Pues pude cambiar la MAC tanto en el menú Version como en (supuestamente) el sistema. Digo «supuestamente» porque cuando le pido un comando para que muestre wlan0 muestra la MAC que le quiero dar, pero si veo en configuración avanzada de Wifi sigue la MAC problemática. Además, la MAC del bluetooth empieza por 40:5f, mietras que la que muesta en avanzadas es 41:5f.

              Cuando cambié la MAC trata al menos de autenticarse (eso lo probé en el trabajo), cosa que no hacía antes. Más tarde pruebo otra conexiones a ver qué sucede.

              Edit:
              Bueno, parece que el asunto sí era de direcciones MAC. Modifiqué los archivos de configuración para cambiar ese parámetro y ahora todo funciona a las mil maravillas! Tan pronto tenga un tiempo hago un manualito al respecto (no es tan complicado).

              A @BreakkBreakk, gracias por tu ayuda. Me diste la pista inicial para poder arreglar mi problema!
               
              Última edición por un moderador: 30 Dic 2013
            • lucario93

              lucario93 Simdualero de Bronce

                12
                0
                23 Mar 2012
                oye!! y el tutorial!! es que a mi me pasa lo mismo!! :TT TT: y llevo dias sin poder usarlo!!:mah (chilling):
                 
              • shouled

                shouled Simdualero de Bronce

                  Me disculpo por no aportar nada de esto hace rato.

                  Mini-tutorial guia rápida para arreglar el problema de la MAC WiFi en el Alcatel 890D:


                  Antes que nada, quiero aclarar que este tutorial es meramente didáctico y que está pensado para arreglar problemas básicos de conexión por Wifi con el equipo Alcatel 890D. En algunos países es ilegal hacer cambio de MAC a los equipos, así que no me responsabilizo por el uso que se le dé a esta información.

                  1) Buscar la MAC de nuestro equipo en el menú Factory (se obtiene al encender el equipo oprimiendo al tiempo abajo y PWR).
                  2) Anotar el número de MAC Wifi que aparece ahí. Es lo que necesita nuestro equipo para funcionar.
                  3) Instalar un explorador de root como root Explorer. Por supuesto, el teléfono tiene que estar rooteado. Esto se hace con Super One Click.
                  4) Buscar la dirección MAC Wifi actual de nuestro equipo en Ajustes del sistema - Acerca del teléfono - Estado.
                  3) Anotar el número de la MAC Wifi actual. Este es el número que debemos cambiar.
                  4) Una vez instalado el explorador root, montar como R/W y buscar el archivo WIFI CUSTOM en la carpeta /data/nvram/APCFG/APRDEB del equipo.
                  5) Copiar el archivo WIFI CUSTOM a la tarjeta SD.
                  6) Conectar el equipo como medio extraíble y hacer una copia de seguridad del archivo WIFI CUSTOM.
                  7) Abrir el archivo WIFI CUSTOM con un editor hexadecimal. Para windows, recomiendo HxD.
                  8) Buscar el número MAC Wifi actual y reemplazarlo por el número MAC Wifi que encontramos en el menú Factory. Guardar los cambios.
                  9) Desconectar el equipo como medio extraíble.
                  10) Abrir el explorador root y buscar el archivo que hemos modificado. Generalmente, la SD se encuentra en /mount/sdcard.
                  11) Seleccionar el archivo que modificamos y copiarlo en la carpeta en donde estaba originalmente. Si nos sale una confirmación de sobreescribir, aceptamos.
                  12) Seleccionamos el archivo que acabamos de copiar y le asignamos los permisos rw-r-x--- , es decir:
                  Owner: Read, Write
                  Group: Read, Execute
                  Others: Ninguno
                  Special permisions: Ninguno
                  13) Reiniciamos el equipo. Ahora debe funcionar la conexión Wifi.

                  Espero que les sea útil.

                  Salut!
                   
                Verificación:
                Borrador guardado Borrador eliminado

                Compartir esta página

                Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.