Pulsa aquí para quitar la publicidad.

PROBLEMA No funciona correctamente el sensor de proximidad

Tema en 'Xiaomi Redmi 3 Snapdragon 616' iniciado por Garbage, 24 Mar 2016.

  1. Garbage

    Garbage Para aprender y ayudar en lo que pueda y sepa Simdualero de Diamante

    • Veteran@
    1.255
    718
    17 Nov 2012
    Salamanca
    Buenas!

    Me acabo de encontrar con el primer problema "serio" en mi Redmi 3. Y es que ayer por la tarde lo tenía apoyado en la mesa, lo fui a desbloquear y me apareció esta pantalla:
    [​IMG]
    La imagen no es la de mi móvil porque no pude hacerle foto, pero vamos, salía eso, aunque en español, claro.

    Por si alguien no lo sabe, esta pantalla aparece cuando tienes activada la opción Prevenir llamadas accidentales, dentro de la opción Pantalla de bloqueo en Ajustes. Lo que hace esa opción es evitar que cuando llevas el móvil en el bolsillo por accidente se te desbloquee y te haga llamadas no deseadas. Para ello se apoya en el sensor de proximidad para detectar si está metido o no en un bolsillo.

    Pues bien, que apareciera esa pantalla de repente, teniendo el teléfono apoyado en una superficie plana, me hizo sospechar que algo no iba bien con el sensor de proximidad. Al momento me llamaron por teléfono y ahí las sospechas se confirmaron: al separar el teléfono de la oreja no se encendía la pantalla, señal inequívoca de que el sensor se había bloqueado o bien, dañado.

    Mediante el menú ingeniero del móvil hice un test del sensor y, efectivamente, no era detectado. Reinicié el móvil y todo volvió a la normalidad. Volví a activar la opción de prevención de llamadas accidentales y ya está.



    Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)

    Por la noche ya vuelvo a coger el móvil, lo desbloqueo y.... la misma pantalla!! Vamos, que el sensor se había vuelto a "bloquear". Reinicié el terminal y todo bien de nuevo, pero ya me estoy mosqueando porque esto no es normal.

    Por una parte, he dejado desactivada la opción de prevención de llamadas accidentales por si fuera ésta la que diera algún conflicto con el sensor, pero me extraña porque desde hace una semana que lo tengo siempre la he tenido activada y nunca me había pasado eso.

    Por otra parte, he leído que puede ser el protector de pantalla, que no esté bien puesto e "interfiere" con el sensor de proximidad. No sé, la verdad, yo creo que el protector está bien puesto, aunque si sigue el problema probaré a quitarlo por si mejorara el asunto.

    En varios foros del Samsung Galaxy S4 comentaban varios foreros que a ellos no les funcionaba correctamente el sensor de proximidad y descubrieron que era un fallo de diseño del terminal, por el que entraba una cantidad considerable de polvo por el auricular del aparato y "ensuciaba" el sensor y no le dejaba operar con normalidad. En mi caso dudo que sea eso, ya que el teléfono tiene poco más de una semana y no creo que se le haya metido mucho polvo por el auricular....

    En fin, que me tiene algo mosca este tema, la verdad. Si alguien puede aportar algo más de luz al asunto o sabe si hay que probar alguna cosa más, soy todo ojos :smile:

    Un saludo y perdón por el tostón que he soltado :grin::grin:
     
  2. ribanezt

    ribanezt se tu mismo los demas puestos ya estan ocupados Colaborador

      2.450
      3.186
      21 Mar 2015
      Mañolandia
      Ostras no @Garbage@Garbage no lo había visto, a ver si alguien puede aportar luz a este problema...
       
      • Me Gusta Me Gusta x 1
      • Garbage

        Garbage Para aprender y ayudar en lo que pueda y sepa Simdualero de Diamante

        • Veteran@
        1.255
        718
        17 Nov 2012
        Salamanca
        Yo supongo que no es un fallo físico del sensor, porque si no, no funcionaría nunca, y cuando reinicio el terminal se soluciona.

        Por lo pronto he desactivado la característica de Prevenir llamadas accidentales y por ahora no me lo ha vuelto a hacer. Ya os iré contando.

        Saludos.

        Garbage.-
         
      • adamus

        adamus Simdualero de Oro

          187
          126
          27 Mar 2013
          Probablemente sea problema de la ROM.....tienes la oficial o alguna de las traducidas como la 7.3.1.0?.......has probado si con la stock ROM también te pasa?

          Enviado desde mi Redmi 3 mediante Tapatalk
           
        • Garbage

          Garbage Para aprender y ayudar en lo que pueda y sepa Simdualero de Diamante

          • Veteran@
          1.255
          718
          17 Nov 2012
          Salamanca
          @adamus@adamus, tengo la 7.1.3.0.
          Yo también creo que es problema de la ROM, pero lo curioso es que la opción que he comentado antes la dejé activada desde el momento que puse la ROM, hace justamente una semana y no me había fallado hasta ayer. Es lo que me desconcierta. Si esa opción diera fallo, habría fallado desde el primer día, ¿no crees?

          Saludos.

          Garbage. -
           
        • adamus

          adamus Simdualero de Oro

            187
            126
            27 Mar 2013
            @Garbage@Garbage Pudiera ser.....pero no tenemos acceso al recovery del teléfono por el tema del bootloader. Otra cuestión es que decidas desbloquearlo y calibrar el mismo desde el recovery. Yo me esperaría un poco a ver cómo se van desarrollando las roms para tener más información. Si decides desbloquear el bootloader hay que solicitarlo a Xiaomi.

            Enviado desde mi Redmi 3 mediante Tapatalk
             
            • Me Gusta Me Gusta x 1
            • humphrey

              humphrey Simdualero de Platino

                280
                68
                28 Oct 2012
                A mí me ha pasado eso mismo con el Redmi Note 2, pero el sensor aparentemente funciona bien, porque al recibir o hacer llamadas y acercarlo a la oreja se ha apagado la pantalla, que es lo que tiene que hacer, y nunca ha fallado.
                 
              • nonotopi

                nonotopi Simdualero de Plata

                  63
                  9
                  18 Feb 2014
                  AB
                  A mi en el redmi 1 me pasa desde que puse miui v7 debe ser la ROM casi seguro

                  Enviado desde mi 2013023 mediante Tapatalk
                   
                  • Me Gusta Me Gusta x 1
                  Verificación:
                  Borrador guardado Borrador eliminado

                  Compartir esta página

                  Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.