activar banda WCDMA 900 en terminales chinos

D

dougsanti

Simdualero de Plata
11 Oct 2012
53
0
386
San Jose, Costa Rica
+50689382116
#73
Hay un menú escondido en settings que se puede accesar mediante adb de la siguiente forma:

adb shell
am start -n com.android.settings/.BandMode

Alternativamente pude usarse un terminal y solo darle:

am start -n com.android.settings/.BandMode

Los valores normales en Phone.java en framework.jar extraídos de com.android.internal.telephony Phone.smali son:

0 para "unspecified" (selected by baseband automatically)
1 para "EURO band" (GSM-900 / DCS-1800 / WCDMA-IMT-2000)
2 para "US band" (GSM-850 / PCS-1900 / WCDMA-850 / WCDMA-PCS-1900)
3 para "JPN band" (WCDMA-800 / WCDMA-IMT-2000)
4 para "AUS band" (GSM-900 / DCS-1800 / WCDMA-850 / WCDMA-IMT-2000)
5 para "AUS band 2" (GSM-900 / DCS-1800 / WCDMA-850)
6 para "Cellular (800-MHz Band)"

Bien podría probarse a ver si con este otro método se enciende la banda de WCDMA 900 si así lo permite la banda base. Actualización:
Las primeras pruebas indican que se cambian valores modificando el comportamiento del teléfono. Si no conecta del todo simplemente correr de nuevo, seleccionar modo automático y reiniciar el teléfono.

Parece haber algún problema usando Phone.java con teléfonos dual sim, que deberían usar el subfolder Gemini GeminiPhone pues el ril es también GEMINI. De ser el caso, también puede que falte otras definiciones como Phone.NT_MODE_GEMINI y Phone.PHONE_TYPE_GEMINI

Tanto el BandMode en Settings.apk como el EngineerMode.apk parecen no poder funcionar correctamente debido a este detalle.
 
flufy_tendo

flufy_tendo

Ajuste de nivel +5
Diamante
Platino
Cocinero
25 Dic 2012
12.918
7.301
10.476
Galicia
#74
Chicos acaba de aparecer una apk que nos habilita las bandas del 900 y 1800 en el zp900. La he abierto y tiene varios smali pero mas no se.
Aquí os dejo el link https://www.movilesdualsim.com/tema/28255
Es posible que modifique el framework.jar?
Enviado desde mi ZP900 usando Tapatalk 2
 
Última edición por un moderador:
S

smilyar

Simdualero de Bronce
6 Jun 2013
29
0
336
Buenos Aires Argentina
Haier W718
#75
Hola @dougsanti, me he comprado un Haier W718 y soy de Buenos Aires, por lo que este Smartphone tiene banda WCDMA EN 900/2100 y aquí el 3G funciona en 850/1900, me intereso muchísimo tu explicación ya que me abre una posibilidad de habilitarlo por lo menos en 850 que es en la banda que funciona mi operadora en Buenos Aires. Pensaba que a lo mejor yo podría ser donante para la banda de 900 y a cambio alguien podría ser donante mio para la de 850. Estoy recibiendo el equipo este viernes y si te parece ire viendo como extraer los archivos para la donación si es que cuadra. Mil felicitaciones y muchísimas gracias
 
Última edición por un moderador:
S

smilyar

Simdualero de Bronce
6 Jun 2013
29
0
336
Buenos Aires Argentina
Haier W718
#76
Hay un menú escondido en settings que se puede accesar mediante adb de la siguiente forma:

adb shell
am start -n com.android.settings/.BandMode

Alternativamente pude usarse un terminal y solo darle:

am start -n com.android.settings/.BandMode

Los valores normales en Phone.java en framework.jar extraídos de com.android.internal.telephony Phone.smali son:

0 para "unspecified" (selected by baseband automatically)
1 para "EURO band" (GSM-900 / DCS-1800 / WCDMA-IMT-2000)
2 para "US band" (GSM-850 / PCS-1900 / WCDMA-850 / WCDMA-PCS-1900)
3 para "JPN band" (WCDMA-800 / WCDMA-IMT-2000)
4 para "AUS band" (GSM-900 / DCS-1800 / WCDMA-850 / WCDMA-IMT-2000)
5 para "AUS band 2" (GSM-900 / DCS-1800 / WCDMA-850)
6 para "Cellular (800-MHz Band)"

Bien podría probarse a ver si con este otro método se enciende la banda de WCDMA 900 si así lo permite la banda base. Actualización:
Las primeras pruebas indican que se cambian valores modificando el comportamiento del teléfono. Si no conecta del todo simplemente correr de nuevo, seleccionar modo automático y reiniciar el teléfono.

Parece haber algún problema usando Phone.java con teléfonos dual sim, que deberían usar el subfolder Gemini GeminiPhone pues el ril es también GEMINI. De ser el caso, también puede que falte otras definiciones como Phone.NT_MODE_GEMINI y Phone.PHONE_TYPE_GEMINI

Tanto el BandMode en Settings.apk como el EngineerMode.apk parecen no poder funcionar correctamente debido a este detalle.
Hola que otras otras definiciones como Phone.NT_MODE_GEMINI y Phone.PHONE_TYPE_GEMINI estarían faltanto? yo encontré este documento a ver si sirve.
http://pastebin.com/QL6vm12K
saludos
 
D

dougsanti

Simdualero de Plata
11 Oct 2012
53
0
386
San Jose, Costa Rica
+50689382116
#77
Hola @dougsanti, me he comprado un Haier W718 y soy de Buenos Aires, por lo que este Smartphone tiene banda WCDMA EN 900/2100 y aquí el 3G funciona en 850/1900, me intereso muchísimo tu explicación ya que me abre una posibilidad de habilitarlo por lo menos en 850 que es en la banda que funciona mi operadora en Buenos Aires. Pensaba que a lo mejor yo podría ser donante para la banda de 900 y a cambio alguien podría ser donante mio para la de 850. Estoy recibiendo el equipo este viernes y si te parece ire viendo como extraer los archivos para la donación si es que cuadra. Mil felicitaciones y muchísimas gracias
Disculpa que no te hubiese respondido, pero han sido unas semanas bastante ocupadas.
En lo que respecta a este tema de las bandas. Si bien el asunto de software anda por lo que pensaba. También está el asunto del hardware. El procesador es capaz de manejar todas las bandas, pero en lo que es topología MTK 6573, 75 77 y 89 hay dos elementos extra. El procesador se comunica con un switch de bandas, tipo MT6162, 66 etc. Y de los terminales del switch sale a un amplificador específico, por ejemplo SKY77551, 53, 77701 o RFMD RF7241, 42, 44, 45 etc. Banda i es 2100, ii 1900, v 850, iv 1700, viii 900. China Unicom, que es la que usa 3G va con banda i, que es la de 2100 y de ahí que esa sea lo estándar en equipos chinos.
Si bien es posible que se modifique el software para que funcione alguna banda, la conexión con esa banda que el terminal no tenga el amplificador correspondiente será casi nula e inestable. Ya tengo la experiencia modificando un MTK6575, se descompila el framework y se ingertan archivos smali de otro teléfono idéntico al que si le funciona la banda que se quiere. El asunto es que, no da una conexión estable, las llamadas se caen, la conexión de datos entra y sale, no es algo ideal.
Para concluir, esto de los injertos es como la lotería. Si el aparato tiene el hardware y se cambia el modem y los archivos del framework se dan resultados positivos. Mientras más elementos de hardware falten, mas imposible es que se obtenga resultado positivo. Si el software no está presente, lo más posible es que el fabricante no pusiera el hardware para que funcione. Como saberlo? Hay que desarmar el aparato y empezar a leer los modelos de chips de RF que tiene y que le falte.
 
Última edición por un moderador:
R

rodo_pang

Simdualero de Bronce
4 Jul 2013
9
0
436
#78
si funcionará el usar el adb terminal para accesar las bandas??
 
J

Julian Gomez

Simdualero de Bronce
20 Sep 2013
12
0
236
#79
Holaa Esta muy bueno el post yo tengo un clon del S3 y un dia tratando de hacer eso instale un programa que vi en otro post en este mismo foro pero las consecuencias fueron malas no tengo senal y Me dice RADIO_NOT_AVIABLE que se le puede hacer es un MTJK6577
 
Kram

Kram

Simdualero de Oro
25 Dic 2012
204
17
826
Madrid (España)
#80
Holaa Esta muy bueno el post yo tengo un clon del S3 y un dia tratando de hacer eso instale un programa que vi en otro post en este mismo foro pero las consecuencias fueron malas no tengo senal y Me dice RADIO_NOT_AVIABLE que se le puede hacer es un MTJK6577
Si hiciste copia de seguridad recuperala, sino pide a alguien que tenga el terminal una copia
 
J

Julian Gomez

Simdualero de Bronce
20 Sep 2013
12
0
236
#81
Ok mucho gusto mi nombre es julian Soy nuevo en este foro alguien seria tan hamable darme una copia de sefuridad
 
S

soa2013

Simdualero de Plata
12 Sep 2013
97
6
625
#82
hola como andan, muy bueno el post y muy interesante, yo tambien soy de argentina, y compre un lenovo a820, existe alguna posibilidad de habilitar la banda de 850mhz en ese modelo? desde ya muchas gracias
 
inigoml

inigoml

Simdualero de Plata
6 Sep 2013
70
16
318
#83
Disculpa que no te hubiese respondido, pero han sido unas semanas bastante ocupadas.
En lo que respecta a este tema de las bandas. Si bien el asunto de software anda por lo que pensaba. También está el asunto del hardware. El procesador es capaz de manejar todas las bandas, pero en lo que es topología MTK 6573, 75 77 y 89 hay dos elementos extra. El procesador se comunica con un switch de bandas, tipo MT6162, 66 etc. Y de los terminales del switch sale a un amplificador específico, por ejemplo SKY77551, 53, 77701 o RFMD RF7241, 42, 44, 45 etc. Banda i es 2100, ii 1900, v 850, iv 1700, viii 900. China Unicom, que es la que usa 3G va con banda i, que es la de 2100 y de ahí que esa sea lo estándar en equipos chinos.
Si bien es posible que se modifique el software para que funcione alguna banda, la conexión con esa banda que el terminal no tenga el amplificador correspondiente será casi nula e inestable. Ya tengo la experiencia modificando un MTK6575, se descompila el framework y se ingertan archivos smali de otro teléfono idéntico al que si le funciona la banda que se quiere. El asunto es que, no da una conexión estable, las llamadas se caen, la conexión de datos entra y sale, no es algo ideal.
Para concluir, esto de los injertos es como la lotería. Si el aparato tiene el hardware y se cambia el modem y los archivos del framework se dan resultados positivos. Mientras más elementos de hardware falten, mas imposible es que se obtenga resultado positivo. Si el software no está presente, lo más posible es que el fabricante no pusiera el hardware para que funcione. Como saberlo? Hay que desarmar el aparato y empezar a leer los modelos de chips de RF que tiene y que le falte.
Perdona @dougsanti
De todos los post que he leído acerca de las baseband este es de los más clarificadores. No obstante, el tema del ampli me deja descompuesto.
Dado que estamos buscando WCDMA 900, el ampli que use ya debe estar preparado para los 900Mhz dado que GSM usa esa misma banda...
 
Nadie verá tu email. La utilizamos para contactarte y confirmar tu comentario.

Miembros conectados

  • grembo1
  • varelon
  • etijer
  • Gua77
  • zoyB
  • yayo_75
  • kefelizsoi
  • salva.cortellpicot
  • tramankulu
  • vejestorix
  • AEA
  • mcs
  • ajlm1975
  • petux
  • Pebbless1986
  • angekcc
  • bryzer84
  • aaminotti
  • chiqui11
  • segnini
... y 92 más.