Intento 2.3.6 en HD7/H7300

samarkanda

Simdualero de Diamante
12 Oct 2011
3.159
154
2.103
#1
Después de prácticamente desechar la idea de poder crear una rom ICS para nuestros móviles, el siguiente intento es poder crear una rom 2.3.6 adaptándola de otro dispositivo.

Para empezar me he descargado una rom 2.3.6 de un dispositivo bastante parecido al nuestro (el x18i).
La rom está bajada de la página rusa.
Es ESTA.

1.- De esa rom lo único que cambié en un principio fue el boot y el logo.img, poniendo unos de una de las roms del HD7.
Se flashea sin ningún problema. El teléfono arranca sin problemas.

Funciona:
- Teléfono propiamente dicho.
- Datos.
- Wifi.
- Gps, funciona pero en su línea habitual para el HD7.
- Bluetooth.
- Sensor de gravedad.
- Led notificaciones.

No funciona:
- Radio FM: ejecuta la apk pero nada más.
- Cámara : se cierra al arrancar (el proceso android ... se ha cerrado inesperadamente).
- Brújula.
- Leds del flash

2.- Con el Winmerge he comparado ambas roms. Al principio quería ser demasiado ambicioso modificando demasiadas cosas a la vez. Con lo cuál, evidentemente el teléfono no arrancaba, quedándose en el bootanimation.
Después, pues ya he dicho, tendrá que ser poco a poco. Entonces he cambiado todos los .ko (y sólo eso) con el mismo nombre y que existan en ambas, de la rom 2.3.6 del x18i por los del la 2.3.5 nuestra, poniendo además la banda base de octubre.

El teléfono arranca, pero tiene los mismos problemas que en el caso anterior.

Proyecto 4

3.- Pues si cambiando los .ko sigue igual, vamos a probar cambiando todos los .so igual que en el apartado anterior. Meeeeeccccc, error.
El teléfono deja de arrancar, quedándose en el bootanimation.

El próximo intento quizá sería localizar los .so que afectan a lo que no funciona, cambiarlos por la 2.3.5 y a ver si hay suerte. Ahora no tengo tiempo.

==========================================================================​

Este hilo esta creado para intentar adaptar una rom 2.3.6 al HD7. El que quiera descargársela e instalarla, pues él mismo, pero ya está dicho que muchas cosas no funcionan. Son bienvenidos consejos , ayudas, infos, etc ... Ahhhh y también muchos ánimos :tonguewink:acman::tonguewink:acman:

@eduardomo, @haiduongbk, @hammy (ya se que no puedes, pero para que estés informado, XD), @l0rdraiden y todo aquel que pueda colaborar ...

@zoyB, @jman0, @Veloz46, @breakk, no estaremos haciendo otro disparate, como el de la ICS ¿no?

Un saludo
 
Última edición por un moderador:
20 Dic 2010
4.599
398
3.648
Asturias, España
#2
@samarkanda, ningún disparate. Recuerda mi odisea para conseguir que la rom blue del HD7+ funcionara en el B63M. Me volvieron loco el acelerómetro y el sensor magnético, pero a base de coger archivos .so y .ko de una rom del B63M en la que funcionaban al final lo logré. Eso sí, no me preguntes cuáles eran esos archivos, que ya ni me acuerdo :smile:
 
Última edición por un moderador:

samarkanda

Simdualero de Diamante
12 Oct 2011
3.159
154
2.103
#3
Bueno pues entonces al lío.
He probado con un parche a meter únicamente los .so de la cámara de la 2.3.5 del HD7, para ir solucionando cosas poco a poco:
libcamera_client.so, libcameracustom.so y libcameraservice.so de la carpeta system/lib (al menos entiendo yo que son esos)

El teléfono no arranca. Algo se escapa.
 
30 Ago 2011
1.517
155
2.183
Sevilla
#4
A ver, pregunta. ¿Necesitara la ROM o los .ko su kernel? ¿@jman0, cambiaste el boot.img del HD7 por el del B69? ¿O dejaste el del HD7?
 
Última edición por un moderador:
20 Dic 2010
4.599
398
3.648
Asturias, España
#5
A ver, pregunta. ¿Necesitara la ROM o los .ko su kernel? ¿@jman0, cambiaste el boot.img del HD7 por el del B69? ¿O dejaste el del HD7?
El boot.img era el del B63M, porque sino, no hay manera. En vuestro caso, supongo que necesitaréis usar el del HD7+
 
Última edición por un moderador:

samarkanda

Simdualero de Diamante
12 Oct 2011
3.159
154
2.103
#6
El boot es el del HD7.
Si meto los ko del hd7 el telefono arranca bien.
En cuanto se toca los .so se acabo.

¡¡Pero no toques!! ¿¡Por qué tocas!? Aymai.
Desde Tapatalk.
 
30 Ago 2011
1.517
155
2.183
Sevilla
#7
libcamera_client.so, libcameracustom.so y libcameraservice.so de la carpeta system/lib (al menos entiendo yo que son esos)

El teléfono no arranca. Algo se escapa.
Pues como no pruebes cambiar de uno en uno, o combinaciones de dos en dos...
 

samarkanda

Simdualero de Diamante
12 Oct 2011
3.159
154
2.103
#8
Se me ha ocurrido otra cosa.
En la página de @haiduongbk he visto que la 5.1 (2.3.6 de no se que modelo) suya ya tenía corregido la radio y la cámara funcionaba a 5 mp (total el sensor es de 3,2).
No recuerdo el flash. La brújula seguro que no iba.

Esta tarde me pondré al lío con esta rom.

Hala
 
Última edición por un moderador:

eduardomo

Simdualero de Diamante
30 Dic 2011
1.126
479
1.789
Roses - Girona
#9
Se me ha ocurrido otra cosa.
En la página de @haiduongbk he visto que la 5.1 (2.3.6 de no se que modelo) suya ya tenía corregido la radio y la cámara funcionaba a 5 mp (total el sensor es de 3,2).
No recuerdo el flash. La brújula seguro que no iba.

Esta tarde me pondré al lío con esta rom.

Hala
Ya te dije de comenzar por ahí :tonguewink:
 
Última edición por un moderador:
20 Dic 2010
4.599
398
3.648
Asturias, España
#10
Se me ha ocurrido otra cosa.
En la página de @haiduongbk he visto que la 5.1 (2.3.6 de no se que modelo) suya ya tenía corregido la radio y la cámara funcionaba a 5 mp (total el sensor es de 3,2).
No recuerdo el flash. La brújula seguro que no iba.

Esta tarde me pondré al lío con esta rom.

Hala
Yo probé en el B63M la primera 2.3.6 que sacó @haiduongbk para el HD7+ y funcionaba bastante fluida, excepto por el hecho de que la pantalla me salía invertida. Bueno, la magen salía bien, pero si tocaba abajo a la derecha reaccionaba arriba a la izquierda. Fue divertido tratar de apagarlo sin quitar la batería.

En fin, aparte de la anécdota, quiero decir que teniendo una base, y con cosas que funcionan de una y otra rom es posible hacer un frankenstein (os cedo el nombre para la nueva rom si lo lográis) y que os funcione, pero hay que tener mucho tiempo y paciencia, ya que cada mínimo cambio es un flasheo, y un rollo.
 
Última edición por un moderador:
30 Ago 2011
1.517
155
2.183
Sevilla
#11
Pero si ya está hecho esto por @haiduongbk... Que gracia tiene este post? No será mejor liarse la manta a la cabeza con la 2.3.7 de @chaskaman??
 
Última edición por un moderador:

samarkanda

Simdualero de Diamante
12 Oct 2011
3.159
154
2.103
#12
Pero si ya está hecho esto por @haiduongbk... Que gracia tiene este post? No será mejor liarse la manta a la cabeza con la 2.3.7 de @chaskaman??
Chaskaman tiene casi todos drivers en el boot. Como debe ser. Los nuestros estan desparramados por media rom.
El de chaskaman es unisim...
Es que no sabria ni por donde empezar.
Seria mejorar lo que ya hay. Meter los ajustes CM, el ext2 que no lo lleva, etc etc

¡¡Pero no toques!! ¿¡Por qué tocas!? Aymai.
Desde Tapatalk.
 
Última edición por un moderador: