Pulsa aquí para quitar la publicidad.

Notificaciones en segundo plano

Tema en 'Huawei Honor 6 HiSilicon Kirin 920' iniciado por mnemic, 11 Sep 2014.

  1. mnemic

    mnemic Simdualero de Platino

      289
      51
      19 Ago 2013
      Hola chicos, hace 2 días que trasteo el móvil y me he encontrado con este problema. Había leído mucho antes de recibir el móvil sobre la forma en la que gestione Huawei las aplicaciones, tienes que darles permisos individualmente a cada aplicación para que pueda acceder a la ID, a los contactos, al WLAN, etc. Además tienes que decirle que cuando se apague la pantalla siga abierta en segundo plano y darle permisos también para que te lleguen las notificaciones.

      Pues bien, lo tengo todo configurado para que tanto Whatsapp, Line como Telegram, Gmail puedan notificarme, se queden en segundo plano y accedan a todos los permisos que necesitan. Aun así, no recibo sus notificaciones en cuanto el LCD se apaga, pero el problema es que aunque encienda el LCD siguen sin llegarme hasta que abro las aplicaciones y entonces sí se me actualizan.



      Enlaces Patrocinados: (regístrate o inicia sesión y no te molestarán más)

      Pensé que era algo relacionado con la suspensión del WiFi al apagarlo, pero también lo tengo en máximo rendimiento y sin ahorro de energía, también tengo el Uso de Batería en Rendimiento para que no suspenda ninguna aplicación. He probado a quitar el WiFi y dejarla sólo con datos, pero el resultado es el mismo. Cuando salgo de una app hacia el Launcher, no lo hago con el botón "back", lo hago con el "home" para forzar a que se queden en segundo plano, pero nada, no hay manera. Me da que aunque la marques como permitida para que se quede en segundo plano al apagar la pantalla, no lo hace.

      En el mega-hilo de XDA hay otra única persona (italiana, si no recuerdo mal) que tiene el mismo problema con Whatsapp y Gmail, pero no lo ha conseguido solucionar y le insisten en que es cosa de la configuración de esta gestión. Como sé que no es algo generalizado, debe ser alguna app que tiene él y que tengo yo que nos bloquea las notificaciones. Pero lo curioso es que la aplicación de Mail con una cuenta de Outlook Web Access (Exchange) sí funciona a las mil maravillas!!

      Después de todo este tocho, alguna ayudita? Alguna idea de lo que puedo hacer? La última opción es volver a fábrica y empezar de cero sólo con esas apps que me dan problemas, pero no podré hacerlo hasta el finde, y de poco me sirve tener un smartphone si no es lo suficientemente "smart" para avisarme de mis notificaciones.

      Saludos!!
       
    • joroge

      joroge Simdualero de Plata

        69
        21
        14 Ago 2014
        Buenas!!!

        Yo también había leído sobre el tema y me esta pasando lo mismo, aun teniendo el gestor de permisos desactivado.

        Lo que acabo de hacer es aplicarle el check de aplicación de confianza.

        [​IMG]

        No se si irán por aquí los tiros.

        Tengo la b118sp02 recién instalada y con hard reset de por medio.

        Saludos.
         
        Última edición por un moderador: 31 Mar 2015
        • Me Gusta Me Gusta x 1
        • mnemic

          mnemic Simdualero de Platino

            289
            51
            19 Ago 2013
            Eso también lo he hecho, pero nada. A ver si va a ser algún problema de la B118SP02... Has probado quitándole el WiFi? Te iba con versiones anteriores? Yo no lo he probado con ninguna otra versión, porque tal como vino, lo actualicé. A ver si alguien más nos explica su experiencia...

            Pregunta, llevas algún launcher especial? Tienes el bootloader desbloqueado y el terminal rooteado?
             
            Última edición por un moderador: 31 Mar 2015
          • joroge

            joroge Simdualero de Plata

              69
              21
              14 Ago 2014
              Con la b113 me pasaba exactamente igual, por eso he actualizado...

              Sin wifi también me pasa...

              La rom totalmente de origen, ni bootloader abierto, ni root ni nada...

              A mi ahora parece que me funciona, porque no tenia puesto lo de permitir la ejecución en segundo plano.

              Voy comentando experiencia.

              Saludos.
               
            • joroge

              joroge Simdualero de Plata

                69
                21
                14 Ago 2014
                @mnemic@mnemic parece que ya me funciona todo bien...

                Estaba cenando y el movil sonando todo el rato llegando whatsapp, correos de gmail, etc...

                En mi caso era el tema de ejecucion en segundo plano.

                Tambien he reiniciado el movil por si acaso, ya se que no es un windows... pero nunca viene mal jejejejeje
                 
              • mnemic

                mnemic Simdualero de Platino

                  289
                  51
                  19 Ago 2013
                  Yo lo he apagado y vuelto a encender y sigue igual. Tengo dado permisos para que se ejecuten en segundo plano, pero parece que a mí no me funciona bien esa parte. Seguiré buscando soluciones. Qué rabia!!!

                  Enviado desde mi LG-V500 mediante Tapatalk
                   
                • joroge

                  joroge Simdualero de Plata

                    69
                    21
                    14 Ago 2014
                    Después de actualizar hicistes un hard reset?

                    Yo es que he dado permisos a diestro y siniestro :smile: y desactivando cualquier tipo de control o ejecución...
                     
                  • sakil

                    sakil Simdualero de Platino

                    • Veteran@
                    749
                    385
                    23 Dic 2012
                    Badajoz
                    El problema viene por no hacer Wipes casi al 100%, por eso siempre se recomienda. A mi me pasaba con el Honor 3X aveces y haciendo wipes antes de flashear y por si acaso después ya me funcionaba bien...

                    Ya nos cuentas tu experiencia y si...es una faena tener que configurar todo de nuevo :dizzy:
                     
                  • mnemic

                    mnemic Simdualero de Platino

                      289
                      51
                      19 Ago 2013
                      Hice wipes antes y después. Pero volveré a hacerlos a ver si eso lo soluciona. Qué remedio...
                       
                    • sakil

                      sakil Simdualero de Platino

                      • Veteran@
                      749
                      385
                      23 Dic 2012
                      Badajoz
                      Me pareció entender que no... los 4 wipes no??? Que hay otro en avanzados...por si acaso...

                      Suerte! y revisa todo despacio porque no es normal...
                       
                    • mnemic

                      mnemic Simdualero de Platino

                        289
                        51
                        19 Ago 2013
                        Qué cachondo es mi móvil... No sé por qué pero los wipes no funcionan... Me dice que ya está hecho, pero al reiniciarme el móvil está igual!!! Tengo el recovery de fábrica, voy a poner un CWM y probaré esos wipes, pero luego volveré al de fábrica, que me gusta que me salten las OTAs...
                         
                      • joroge

                        joroge Simdualero de Plata

                          69
                          21
                          14 Ago 2014
                          Puede ser que vayan por aquí los tiros???

                          [​IMG]
                           
                          Última edición por un moderador: 31 Mar 2015
                          • Me Gusta Me Gusta x 1
                          Verificación:
                          Borrador guardado Borrador eliminado

                          Compartir esta página

                          Galletas! Nos obligan a informar que utilizamos cookies (como casi todas las webs). Al continuar navegando aceptas su uso.