Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4

franjhv

franjhv

Diamante
Cocinero
24 Abr 2015
9.207
17.361
12.387
En un pais multicolor
Zapatofono
#1
Voy a intentar hacer un tutorial sencillo para instalar Xposed Framework en nuestro Meizu M2, lo hare primero para quien tiene el bootloader desbloqueado y en el segundo post para quien, todavía lo tiene bloqueado (es un poco mas complicado).
De paso ya que nos ponemos en faena pues os propongo instalar FlymeTools 1.8.6 en español que traduje yo para unos compañeros ya hace algo de tiempo (última versión para Flyme 4 que he encontrado). Esta app es conocida como el Gravity box para Flyme.

ACTUALIZACION 02/06/16: Este tutorial solo se puede realizar en roms basadas en Flyme 4, en Flyme 5 para el m2, al ser versiones beta ,no se ha podido activar Xposed Framework (de momento). Con la version global 5.1.6G si se puede instalar y activar Xposed

Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s60224-111625-jpg.113153
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s60224-111649-jpg.113155

Instalación Xposed Framework con bootloader desbloqueado:

1. Instalar Xposed:
Para instalar Xposed Framework necesitamos unos requisitos:
- Ser usuario root: tener instalado SuperSu y tener los binarios actualizados.
- Busybox instalado y actualizado.

Una vez que tenemos estos requisitos vamos a instalar Xposed.
- Descargamos e instalmos la última versión del instalador de Xposed, en este caso yo he utilizado: XposedInstaller_3.0_alpha4.apk, es la última disponible en xda-developers: [OFFICIAL] Xposed for Lollipop/Marshmallow [Android 5.0/5.1/6.0, v80, 2016/02/02] , esta al final del primer post de esa página. Se instala como cualquier aplicación normal, pinchas y te pregunta si quieres instalar y le dices que si.
- Como necesita permisos root, yo lo que suelo hacer es abrir la app una vez instalada y aunque dice que no esta activa y que requiere un reinicio para estar activada (eso ya lo sabemos y esta controlado), nos vamos a Framework y le damos a Reinicio suave, nos saltará SuperSu preguntando si le damos permisos root, le decimos que si y Xposed ya tiene permisos root (sigue estando desactivado).
- Descargamos del mismo sitio anterior el zip con la última version de Xposed, debe ser algo así: xposed-vXX-sdk22-arm64.zip, donde XX es el número de la version (actualmente es la v80). Esta en la misma página a continuación de XposedInstaler.
- Ahora reiniciamos en recovery (vol up + power) y nos vamos a instalar, buscamos nuesto zip de Xposed en la carpeta que lo hayamos guardado y deslizamos para instalar. Cuando termine le damos a reiniciar y a tener un poco de paciencia, porque si se ha hecho correctamente se tienen que optimizar todas las apps instaladas, se producirán unos cuantos reinicios. En caso de que las apps no se optimicen después de cada bootloop y no baje el contador se puede probar a apagar y encender el dispositivo de forma manual manteniendo pulsado power unos 10 segundos para que se optimicen las apps (esto es raro pero a veces pasa).
Cuando termine de optimizar las apps y arranque el móvil si abrimos la app de Xposed ahora nos dirá que ya está activo.
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s51224-190946-jpg-108434-jpg.253477

Ya podriamos instalar la app Flyme Tools en inglés, pero como nosotros somos más cómodos y no nos molesta complicarnos un poquitín la vida vamos a instalarla en español, para eso vamos a parchear el sistema para que nos permita instalarla (al estar modificada, da un problema de autentificación).

2.Instalar Flyme Tools en español:

Para esto necesitamos descargarnos este rar con lo necesario, la app LuckyPatcher y FlymeTools traducido: [HIDE]https://mega.nz/#!zMsVgDzB!w0B2XeXOahj2YYRlQHZF6Oh5Qud7LYCqJT4hqQfyFkk[/HIDE]
Lo descomprimimos y copiamos al teléfono.

- Primero instalamos LuckyPatcher, como cualquier aplicación normal, pinchamos y nos pregunta si queremos instalar, le decimos que sí y cuando termine en la barra de notificaciones nos saldra un mensaje de Xposed: módulo instalado pero no activado (o algo similar), entramos en Xposed>Módulos y nos saldrá LuckyPatcher pero estará la casilla sin marcar, marcamos y reiniciamos.
- Cuando arranque entramos en Xposed>Módulos para asegurarmnos de que LuchyPatcher está activo, verificamos que está bien, salimos y abrimos LuckyPatcher, para darle permisos root, de todas formas hay que darselos pero yo prefiero darselos ahora y evitar problemas después:
- En la esquina superior derecha, pinchamos en los 3 puntitos verticales y seguidamente pinchamos en Xposed settings y le damos a aplicar, nos pedira permisos root y le decimos que si, con esto hemos hecho 2 cosas al mismo tiempo: darle permisos root y aplicar los parches a las aplicaciones Xposed.
- Reiniciamos otra vez y esperamos unos 15-20 segundos antes de hacer nada, asi nos aseguramos que todas las apps consiguen los permisos root necesarios.
NOTA: Si os salta una actualización de LuckyPatcher y teneis pensado actualizar hacedlo antes de instalar FlymeTools porque si instalais la nueva versión de LuckyPatcher y ya teneis instalado FlymeTools en español, se os desactivará y tendreis que desinstalar FlymeTools y volver a instalarlo para activarlo.

- Ahora vamos donde tenemos FlymeTools en español y le pinchamos, nos pregunta si instalar y le decimos que si y cuando termine de instalar, nos volvera a salir el mismo mensaje que con el LuckyPatcher: módulo instalado pero no activado.
- Entramos en Xposed>Módulos y nos saldrá FlymeTools pero estará la casilla sin marcar, marcamos y reiniciamos.
Si abrimos FlymeTools antes de reiniciar nos saldra esto:
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s60224-122756-jpg.113180

Al estar el fondo en rojo quiere decir que no está activo y si cambiamos algo los cambios no surtiran efecto, así que a reiniciar tocan.
Después de reiniciar , me suelo esperar 15-20 segundos para que todo lo que necesite permisos root los obtenga, si entramos en FlymeTools ya lo tendremos activo y saldrá algo como esto:
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s60224-111625-jpg.113181



Ahora ya podremos personalizar nuestro dispositivo a nuestro gusto dentro de las muchas posibilidades que tiene este modulo de Xposed.

Espero no haber sido muy pesado ni haberlo hecho muy dificil, ante cualquier duda preguntad, gracias.

Fuentes:
[TUTORIAL] Instalar Xposed Framework en Meizu M2 Note
[OFFICIAL] Xposed for Lollipop/Marshmallow [Android 5.0/5.1/6.0, v80, 2016/02/02]

Agradecimientos:
- @iicc por su tutorial en Htcmania.
- xda-developers en general por todo el desarrollo que realizan en el mundo android.
- @antonioantuan por ser él quien encontro LuckyPatcher para poder activar Flyme Tools traducido.
- @Feligres porque nos enseño a todos el protocolo correcto para activar FlymeTools.
 
Última edición:
franjhv

franjhv

Diamante
Cocinero
24 Abr 2015
9.207
17.361
12.387
En un pais multicolor
Zapatofono
#2
ATENCIÓN: Este tutorial solo se puede realizar en roms basadas en Flyme 4, en Flyme 5 para el m2, al ser versiones beta ,no se ha podido activar Xposed Framework (de momento)
Instalación Xposed Framework con bootloader bloqueado:

1. Instalar Xposed:
Para instalar Xposed Framework necesitamos unos requisitos:
- Ser usuario root: tener instalado SuperSu y tener los binarios actualizados.
- Busybox instalado y actualizado.
- Terminal Emulator for Android instalado (yo utilizo este porque nunca me ha dado ningún problema pero hay muchos podeis elegir el que más rabia os de).

Una vez que tenemos estos requisitos vamos a instalar Xposed.
- Descargamos e instalmos la última versión del instalador de Xposed, en este caso yo he utilizado: XposedInstaller_3.0_alpha4.apk, es la última disponible en xda-developers: [OFFICIAL] Xposed for Lollipop/Marshmallow [Android 5.0/5.1/6.0, v80, 2016/02/02] , esta al final del primer post de esa página. Se instala como cualquier aplicación normal, pinchas y te pregunta si quieres instalar y le dices que si.
- Como necesita permisos root, yo lo que suelo hacer es abrir la app una vez instalada y aunque dice que no esta activa y que requiere un reinicio para estar activada (eso ya lo sabemos y esta controlado), nos vamos a Framework y le damos a Reinicio suave, nos saltará SuperSu preguntando si le damos permisos root, le decimos que si y Xposed ya tiene permisos root (sigue estando desactivado).
- Descargamos del mismo sitio que descargamos el zip con la última version de Xposed, debe ser algo así: xposed-vXX-sdk22-arm64.zip, donde XX es el número de la version (actualmente es la v80). Esta en la misma página a continuación de XposedInstaler. Lo copiamos a la raiz de la memoria insterna, es decir en la carpeta /sdcard.
- Descargamos el instalador que hizo el compañero @iicc para el note pero que funciona igual en el mini (yo lo hice asi antes de desbloquear el bootloader) de aqui: [HIDE]https://mega.nz/#!zJlzjJKb!ucqbD_LCrC1-XdgIRV039vS_bkKPLKwnqRz6q6_Go8k[/HIDE] y lo copiamos a la raiz de la memoria insterna, es decir en la carpeta /sdcard. En el explorador de archivos se veria asi (los 2 archivos que están seleccionados son los que necesitamos para desbloquear el bootloader :
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 acdnmovilesdualsim_2834-kxcdn-com_data_metamirrorcache_i-imgur17254a4f5d4ee5357720f821c8b6139b-png.149120


- Abrimos la Terminal Emulator y escribimos: su
Nos dirá si queremos dar permisos root y aceptamos.
- Escribimos: sh /sdcard/installer.bin
Y el proceso de instalación de Xposed empezará.
- Cuando termine le damos a reiniciar y a tener un poco de paciencia, porque si se ha hecho correctamente se tienen que optimizar todas las apps instaladas, se producirán unos cuantos reinicios. En caso de que las apps no se optimicen después de cada bootloop y no baje el contador se puede probar a apagar y encender el dispositivo de forma manual manteniendo pulsado power unos 10 segundos para que se optimicen las apps (esto es raro pero a veces pasa).
Cuando termine de optimizar las apps y arranque el móvil si abrimos la app de Xposed ahora nos dirá que ya está activo.
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s51224-190946-jpg-108434-jpg.253478

Ya podriamos instalar la app Flyme Tools en inglés, pero como nosotros somos más cómodos y no nos molesta complicarnos un poquitín la vida vamos a instalarla en español, para eso vamos a parchear el sistema para que nos permita instalarla (al estar modificada, da un problema de autentificación).

2.Instalar Flyme Tools en español:

Para esto necesitamos descargarnos este rar con lo necesario, la app LuckyPatcher y FlymeTools traducido:
Contenido Visible:
MEGA descomprimimos y copiamos al teléfono.

- Primero instalamos LuckyPatcher, como cualquier aplicación normal, pinchamos y nos pregunta si queremos instalar, le decimos que sí y cuando termine en la barra de notificaciones nos saldra un mensaje de Xposed: módulo instalado pero no activado (o algo similar), entramos en Xposed>Módulos y nos saldrá LuckyPatcher pero estará la casilla sin marcar, marcamos y reiniciamos.
- Cuando arranque entramos en Xposed>Módulos para asegurarmnos de que LuchyPatcher está activo, verificamos que está bien, salimos y abrimos LuckyPatcher, para darle permisos root, de todas formas hay que darselos pero yo prefiero darselos ahora y evitar problemas después:
- En la esquina superior derecha, pinchamos en los 3 puntitos verticales y seguidamente pinchamos en Xposed settings y le damos a aplicar, nos pedira permisos root y le decimos que si, con esto hemos hecho 2 cosas al mismo tiempo: darle permisos root y aplicar los parches a las aplicaciones Xposed.
- Reiniciamos otra vez y esperamos unos 15-20 segundos antes de hacer nada, asi nos aseguramos que todas las apps consiguen los permisos root necesarios.
NOTA: Si os salta una actualización de LuckyPatcher y teneis pensado actualizar hacedlo antes de instalar FlymeTools porque si instalais la nueva versión de LuckyPatcher y ya teneis instalado FlymeTools en español, se os desactivará y tendreis que desinstalar FlymeTools y volver a instalarlo para activarlo.

- Ahora vamos donde tenemos FlymeTools en español y le pinchamos, nos pregunta si instalar y le decimos que si y cuando termine de instalar, nos volvera a salir el mismo mensaje que con el LuckyPatcher: módulo instalado pero no activado.
- Entramos en Xposed>Módulos y nos saldrá FlymeTools pero estará la casilla sin marcar, marcamos y reiniciamos.
Si abrimos FlymeTools antes de reiniciar nos saldra esto:
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s60224-122756-jpg-113180-jpg.253479

Al estar el fondo en rojo quiere decir que no está activo y si cambiamos algo los cambios no surtiran efecto, así que a reiniciar tocan.
Después de reiniciar , me suelo esperar 15-20 segundos para que todo lo que necesite permisos root los obtenga, si entramos en FlymeTools ya lo tendremos activo y saldrá algo como esto:
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s60224-111625-jpg-113181-jpg.253480



Ahora ya podremos personalizar nuestro dispositivo a nuestro gusto dentro de las muchas posibilidades que tiene este modulo de Xposed.

Espero no haber sido muy pesado ni haberlo hecho muy dificil, ante cualquier duda preguntad, gracias.

Fuentes:
[TUTORIAL] Instalar Xposed Framework en Meizu M2 Note
[OFFICIAL] Xposed for Lollipop/Marshmallow [Android 5.0/5.1/6.0, v80, 2016/02/02]

Agradecimientos:
- @iicc por su tutorial en Htcmania del que acabo de hacer un "copia y pega".
- xda-developers en general por todo el desarrollo que realizan en el mundo android.
- @antonioantuan por ser él quien encontro LuckyPatcher para poder activar Flyme Tools traducido.
- @Feligres porque nos enseño a todos el protocolo correcto para activar FlymeTools.
 
Última edición:
franjhv

franjhv

Diamante
Cocinero
24 Abr 2015
9.207
17.361
12.387
En un pais multicolor
Zapatofono
#4
gracias @margal.r , tenia pensado hacer esto hace tiempo pero no habia tenido 2 horas seguidas para hacer un tutorial medio decente, solo intento devolver una pequeña parte de lo que me ha dado este foro.
 
Womitha

Womitha

Simdualero de Plata
15 Feb 2016
90
25
168
#5
Sigue Asi :smile:
 
K

koyado

Simdualero Junior
8 May 2014
4
3
233
#6
Gracias por el auto
 
yaizali

yaizali

Simdualero de Bronce
28 Oct 2015
17
3
169
#8
Gracias por traducirla
 
Kazatek

Kazatek

Simdualero Junior
13 Jun 2016
1
1
113
#9
gracias lo necesitaba
 
F

frmanru

Simdualero Junior
1 Dic 2015
3
4
33
#12
Voy a intentar hacer un tutorial sencillo para instalar Xposed Framework en nuestro Meizu M2, lo hare primero para quien tiene el bootloader desbloqueado y en el segundo post para quien, todavía lo tiene bloqueado (es un poco mas complicado).
De paso ya que nos ponemos en faena pues os propongo instalar FlymeTools 1.8.6 en español que traduje yo para unos compañeros ya hace algo de tiempo (última versión para Flyme 4 que he encontrado). Esta app es conocida como el Gravity box para Flyme.

ACTUALIZACION 02/06/16: Este tutorial solo se puede realizar en roms basadas en Flyme 4, en Flyme 5 para el m2, al ser versiones beta ,no se ha podido activar Xposed Framework (de momento). Con la version global 5.1.6G si se puede instalar y activar Xposed

Ver el adjunto 113153 Ver el adjunto 113155
Instalación Xposed Framework con bootloader desbloqueado:

1. Instalar Xposed:
Para instalar Xposed Framework necesitamos unos requisitos:
- Ser usuario root: tener instalado SuperSu y tener los binarios actualizados.
- Busybox instalado y actualizado.

Una vez que tenemos estos requisitos vamos a instalar Xposed.
- Descargamos e instalmos la última versión del instalador de Xposed, en este caso yo he utilizado: XposedInstaller_3.0_alpha4.apk, es la última disponible en xda-developers: [OFFICIAL] Xposed for Lollipop/Marshmallow [Android 5.0/5.1/6.0, v80, 2016/02/02] , esta al final del primer post de esa página. Se instala como cualquier aplicación normal, pinchas y te pregunta si quieres instalar y le dices que si.
- Como necesita permisos root, yo lo que suelo hacer es abrir la app una vez instalada y aunque dice que no esta activa y que requiere un reinicio para estar activada (eso ya lo sabemos y esta controlado), nos vamos a Framework y le damos a Reinicio suave, nos saltará SuperSu preguntando si le damos permisos root, le decimos que si y Xposed ya tiene permisos root (sigue estando desactivado).
- Descargamos del mismo sitio anterior el zip con la última version de Xposed, debe ser algo así: xposed-vXX-sdk22-arm64.zip, donde XX es el número de la version (actualmente es la v80). Esta en la misma página a continuación de XposedInstaler.
- Ahora reiniciamos en recovery (vol up + power) y nos vamos a instalar, buscamos nuesto zip de Xposed en la carpeta que lo hayamos guardado y deslizamos para instalar. Cuando termine le damos a reiniciar y a tener un poco de paciencia, porque si se ha hecho correctamente se tienen que optimizar todas las apps instaladas, se producirán unos cuantos reinicios. En caso de que las apps no se optimicen después de cada bootloop y no baje el contador se puede probar a apagar y encender el dispositivo de forma manual manteniendo pulsado power unos 10 segundos para que se optimicen las apps (esto es raro pero a veces pasa).
Cuando termine de optimizar las apps y arranque el móvil si abrimos la app de Xposed ahora nos dirá que ya está activo.
Instalación Xposed Framework + Flyme Tools 1.8.6 Español en Flyme 4 s51224-190946-jpg-108434-jpg.269008

Ya podriamos instalar la app Flyme Tools en inglés, pero como nosotros somos más cómodos y no nos molesta complicarnos un poquitín la vida vamos a instalarla en español, para eso vamos a parchear el sistema para que nos permita instalarla (al estar modificada, da un problema de autentificación).

2.Instalar Flyme Tools en español:

Para esto necesitamos descargarnos este rar con lo necesario, la app LuckyPatcher y FlymeTools traducido: ***El contenido oculto no puede ser citado.***
Lo descomprimimos y copiamos al teléfono.

- Primero instalamos LuckyPatcher, como cualquier aplicación normal, pinchamos y nos pregunta si queremos instalar, le decimos que sí y cuando termine en la barra de notificaciones nos saldra un mensaje de Xposed: módulo instalado pero no activado (o algo similar), entramos en Xposed>Módulos y nos saldrá LuckyPatcher pero estará la casilla sin marcar, marcamos y reiniciamos.
- Cuando arranque entramos en Xposed>Módulos para asegurarmnos de que LuchyPatcher está activo, verificamos que está bien, salimos y abrimos LuckyPatcher, para darle permisos root, de todas formas hay que darselos pero yo prefiero darselos ahora y evitar problemas después:
- En la esquina superior derecha, pinchamos en los 3 puntitos verticales y seguidamente pinchamos en Xposed settings y le damos a aplicar, nos pedira permisos root y le decimos que si, con esto hemos hecho 2 cosas al mismo tiempo: darle permisos root y aplicar los parches a las aplicaciones Xposed.
- Reiniciamos otra vez y esperamos unos 15-20 segundos antes de hacer nada, asi nos aseguramos que todas las apps consiguen los permisos root necesarios.
NOTA: Si os salta una actualización de LuckyPatcher y teneis pensado actualizar hacedlo antes de instalar FlymeTools porque si instalais la nueva versión de LuckyPatcher y ya teneis instalado FlymeTools en español, se os desactivará y tendreis que desinstalar FlymeTools y volver a instalarlo para activarlo.

- Ahora vamos donde tenemos FlymeTools en español y le pinchamos, nos pregunta si instalar y le decimos que si y cuando termine de instalar, nos volvera a salir el mismo mensaje que con el LuckyPatcher: módulo instalado pero no activado.
- Entramos en Xposed>Módulos y nos saldrá FlymeTools pero estará la casilla sin marcar, marcamos y reiniciamos.
Si abrimos FlymeTools antes de reiniciar nos saldra esto:
Ver el adjunto 113180
Al estar el fondo en rojo quiere decir que no está activo y si cambiamos algo los cambios no surtiran efecto, así que a reiniciar tocan.
Después de reiniciar , me suelo esperar 15-20 segundos para que todo lo que necesite permisos root los obtenga, si entramos en FlymeTools ya lo tendremos activo y saldrá algo como esto:
Ver el adjunto 113181


Ahora ya podremos personalizar nuestro dispositivo a nuestro gusto dentro de las muchas posibilidades que tiene este modulo de Xposed.

Espero no haber sido muy pesado ni haberlo hecho muy dificil, ante cualquier duda preguntad, gracias.

Fuentes:
[TUTORIAL] Instalar Xposed Framework en Meizu M2 Note
[OFFICIAL] Xposed for Lollipop/Marshmallow [Android 5.0/5.1/6.0, v80, 2016/02/02]

Agradecimientos:
- @iicc por su tutorial en Htcmania.
- xda-developers en general por todo el desarrollo que realizan en el mundo android.
- @antonioantuan por ser él quien encontro LuckyPatcher para poder activar Flyme Tools traducido.
- @Feligres porque nos enseño a todos el protocolo correcto para activar FlymeTools.
 

¿Qué tecnología no debe faltar en tu próximo móvil?

  • NFC

    Votos: 182 46,1%
  • Carga inalámbrica

    Votos: 141 35,7%
  • Carga ultra rápida

    Votos: 228 57,7%
  • 5G

    Votos: 174 44,1%
  • Al menos 3 cámaras principales

    Votos: 113 28,6%
  • Sensor TOF

    Votos: 70 17,7%
  • Lector de huellas

    Votos: 205 51,9%
  • USB tipo C

    Votos: 210 53,2%
  • Bluetooth

    Votos: 189 47,8%
  • Pantalla flexible

    Votos: 34 8,6%

Miembros conectados

  • 38super
  • ktulu69
  • pepetony
  • crispulo miguel romero g.
  • Songokukamehameha
  • damefrikis
  • 666 Rojo
  • mairu
  • cjsegninir
  • avecilla
  • joan36
  • jman0
  • Christian Camaton
  • pepopucela
  • repilado
  • gusrodri
  • lucsar
  • Retube
  • daniville
  • caribe
... y 30 más.