Encryption unsuccessful

J

japd2sim

Simdualero de Bronce
16 Ago 2013
28
1
238
#1
Hola.

Tengo un THL W8 4G. Esta tarde, al coger el teléfono la pantalla estaba apagada y no reaccionaba, así que quité la batería y la volví a colocar. Ahora, cuando enciendo el teléfono aparece el siguiente mensaje:

Encryption unsuccessful.
Encryption was interrupted and can't complete. As a result, the data on your phone is no longer accesible.

El año pasado instalé una ROM (GravityMod si no recuerdo mal) y en aquel momento también instalé un Recovery (ClockWorkMod). Puedo arrancar en modo recovery, pero no sé como solucionar el problema. En su día también hice backups y creo que aún conservo la imagen de la ROM que instalé en su día.

Al arrancar el recovery me aparecen algunos errores de montaje:
E: Can't mount /cache/recovery/command
E: Can't mount /cache/recovery/log
E: Can't mount /cache/recovery/last_log

He intentado limpiar la cache y he intentado un data/factory reset, pero no he logrado ningun avance.

¿Podéis ayudarme a resolver el problema?

Muchas gracias.
 
kekodi

kekodi

Simdualero de Plata
20 Ago 2014
66
13
419
#2
Hola.

Tengo un THL W8 4G. Esta tarde, al coger el teléfono la pantalla estaba apagada y no reaccionaba, así que quité la batería y la volví a colocar. Ahora, cuando enciendo el teléfono aparece el siguiente mensaje:

Encryption unsuccessful.
Encryption was interrupted and can't complete. As a result, the data on your phone is no longer accesible.

El año pasado instalé una ROM (GravityMod si no recuerdo mal) y en aquel momento también instalé un Recovery (ClockWorkMod). Puedo arrancar en modo recovery, pero no sé como solucionar el problema. En su día también hice backups y creo que aún conservo la imagen de la ROM que instalé en su día.

Al arrancar el recovery me aparecen algunos errores de montaje:
E: Can't mount /cache/recovery/command
E: Can't mount /cache/recovery/log
E: Can't mount /cache/recovery/last_log

He intentado limpiar la cache y he intentado un data/factory reset, pero no he logrado ningun avance.

¿Podéis ayudarme a resolver el problema?

Muchas gracias.
Creo que no tiene arreglo, se avería la nand flash y ya no hay manera de hacer nada.
La única solución es cambiar la placa base.
 
xancin

xancin

Diamante
Cocinero
2 Mar 2014
31.632
63.182
23.956
#3
Si que se puede arreglar. Eso sucede a veces cuando se modifican los paremtros de los mbr. Una rom por flashtools escojiendo firmware upgrade y listo
 
J

japd2sim

Simdualero de Bronce
16 Ago 2013
28
1
238
#4
Si que se puede arreglar. Eso sucede a veces cuando se modifican los paremtros de los mbr. Una rom por flashtools escojiendo firmware upgrade y listo
Muchas gracias por la respuesta. Me está costando mucho encontrar los archivos necesarios. Casi todos han desaparecido de los servidores. ¿Donde puedo encontrar una ROM para el THL W8 4 instalable por flashtool? Las que tengo se instalan desde el recovery :-(
 
J

japd2sim

Simdualero de Bronce
16 Ago 2013
28
1
238
#6
Creo que Kekodi va a tener razón. He probado todo lo que se me ha ocurrido y no he avanzado nada:
1. Restaurar el backup que tenía del sistema original con CWM -> falla
2. Flashear ROM original -> falla
3. Flashear custom ROM -> falla
4. Instalar otro recovery -> falla
5. Test de memoria -> Dice que no encuentra la NAND

El SP Flash Tool me dice a veces que el PMT de la ROM ha cambiado y hay que descargarla. He probado a formatear y actualizar el firmware, pero no funciona.

En fin. :-(
 
xancin

xancin

Diamante
Cocinero
2 Mar 2014
31.632
63.182
23.956
#7
y format all mas download?total de perdidos al rio solo pierdes los imei
 
J

japd2sim

Simdualero de Bronce
16 Ago 2013
28
1
238
#8
Sí. He probado las tres opciones del Flash Tool y nada. Desde el recovery también he intentado resetear la configuración, formatear particiones, etc. Y nada. Dice que hace el formato pero luego no se puede escribir la ROM.
 
J

japd2sim

Simdualero de Bronce
16 Ago 2013
28
1
238
#10
@Dr_Rock
Gracias por la respuesta. En dicho menú no me aparece la opción de formatear/montar la emmc. Si veo el resto de puntos de montaje, pero ese concretamente no.

Accediendo al dispositivo con ADB, puedo montar /system y leer su contenido. Sin embargo, me llama la atención que la partición (/dev/block/mmcblk0p7) que se monta en /data no existe. La tabla de particiones del dispositivo /dev/block/mmcblk0 sólo tiene hasta la mmcblk0p6.

Creo que la tabla de particiones se ha corrompido, pero no sé como restaurar la original.
 
J

japd2sim

Simdualero de Bronce
16 Ago 2013
28
1
238
#12
Esto es lo que veo cuando me conecto al teléfono en modo recovery con ADB:

Código:
~ # ls -l /
drwxr-xr-x  2 root  root  0 Jan  1 05:41 boot
drwxr-xr-x  2 root  root  0 Jan  1 05:41 cache
drwxr-xr-x  2 system  system  0 May 28  2013 data
drwxr-xr-x  2 root  root  0 Jan  1 05:41 datadata
-rw-r--r--  1 system  system  2088 May 28  2013 default.prop
drwxr-xr-x  9 root  root  2980 Jan  1 05:41 dev
drwxr-xr-x  2 root  root  0 Jan  1 05:41 emmc
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@android -> /dev/block/mmcblk0p5
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@cache -> /dev/block/mmcblk0p6
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@ebr1 -> /dev/block/mmcblk0p1
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@fat -> /dev/block/mmcblk0p8
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@protect_f -> /dev/block/mmcblk0p2
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@protect_s -> /dev/block/mmcblk0p3
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@sec_ro -> /dev/block/mmcblk0p4
lrwxrwxrwx  1 root  root  20 Jan  1  1970 emmc@usrdata -> /dev/block/mmcblk0p7
drwxr-xr-x  2 system  system  0 Jan  1 05:41 etc
drwxr-xr-x  2 root  root  0 Jan  1 05:41 external_sd
-rwxr-x---  1 system  system  109484 May 28  2013 init
-rwxr-x---  1 system  system  1410 May 28  2013 init.rc
dr-xr-xr-x  90 root  root  0 Jan  1  1970 proc
drwxr-xr-x  3 system  system  0 May 28  2013 res
drwx------  2 root  root  0 Aug  7  2013 root
drwxr-x---  2 system  system  0 May 28  2013 sbin
drwxr-xr-x  2 root  root  0 Jan  1 05:41 sdcard
drwxr-xr-x  2 root  root  0 Jan  1 05:41 storage
dr-xr-xr-x  18 root  root  0 Jan  1 05:41 sys
drwxr-xr-x  3 system  system  0 May 28  2013 system
drwxrwxr-x  2 root  shell  0 Jan  1 05:41 tmp
-rw-r--r--  1 system  system  272 May 28  2013 ueventd.goldfish.rc
-rw-r--r--  1 system  system  5465 May 28  2013 ueventd.rc
Y el archivo fstab muestra los siguientes puntos de montaje:

Código:
~ # cat /etc/fstab
/dev/block/mmcblk0p6 /cache ext4 rw
/dev/block/mmcblk0p7 /data ext4 rw
/dev/block/mmcblk0p5 /system ext4 rw
/dev/block/mmcblk0p8 /sdcard vfat rw
/dev/block/mmcblk1p2 /sd-ext auto rw
/dev/block/mmcblk1p1 /external_sd vfat rw
Y esta es la tabla de particiones

Código:
~ # fdisk -l /dev/block/mmcblk0
Warning: ignoring extra data in partition table 5
Warning: ignoring extra data in partition table 5

Disk /dev/block/mmcblk0: 3780 MB, 3780247552 bytes
1 heads, 16 sectors/track, 461456 cylinders
Units = cylinders of 16 * 512 = 8192 bytes

  Device Boot  Start  End  Blocks  Id System
/dev/block/mmcblk0p1  65  64  2147483647+  5 Extended
Partition 1 does not end on cylinder boundary
/dev/block/mmcblk0p2  1665  2944  10240  83 Linux
Partition 2 does not end on cylinder boundary
/dev/block/mmcblk0p3  2945  4224  10240  83 Linux
Partition 3 does not end on cylinder boundary
/dev/block/mmcblk0p4  5825  6592  6144  83 Linux
Partition 4 does not end on cylinder boundary
/dev/block/mmcblk0p5  8385  91584  665600  83 Linux
/dev/block/mmcblk0p6  435393  64  2144001023+ 83 Linux
Por defecto sólo aparecen montados sistemas de archivos virtuales en el modo recovery:

Código:
~ # mount
rootfs on / type rootfs (rw)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
Pero puedo montar /system y /sdcard:

Código:
~ # mount
rootfs on / type rootfs (rw)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
/dev/block/mmcblk0p5 on /system type ext4 (rw,relatime,data=ordered)
/dev/block/mmcblk0p8 on /sdcard type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
 
Nadie verá tu email. La utilizamos para contactarte y confirmar tu comentario.

Miembros conectados

  • john.cordova
  • zopoo
  • antuna.ricardo
  • chascoberto
  • procris
  • cheo3500
  • F.C
  • seaste
  • jolutomo18
  • samuel serrano cortes
  • josin_xixon
  • Agustindamicotapia
  • Nutricionbronce
  • Minimafy
  • alexisonfire00
  • thetrukos
  • Niko pino
  • sersalvi