Huawei gra-l09 b190

kmlot

kmlot

Simdualero de Bronce
30 Abr 2015
41
0
473
#1
Hola
Tengo un huawei p8 (gra-l09) con firma b190. Android 5.0.1 y miui 3

He desbloqueado el bootloader y quería meter el recovery twrp pero en este paso aunque me dice que esta bien no me sale el recovery, me sigue saliendo el recovery original.
Podéis ayudarme??
Mi intención es meter el recovery para poder rootear el teléfono y después poder usar alguna app que me cambie o enmascare la mac y poder conectar a un router que bloqueo la mac de mi móvil (trabajo)

Porfa podéis ayudarme?

Gracias

P.d: por si sirve de algo antes de desbloquear el bootloader intente hacerme root con el king root pero avecesniba y aveces no, el root checker me indica que soy aveces root pero aun así las apps de cambio de mac no me funcionan. Después empecé este proceso del recovery para meter desde el recovery el superSu y probar.
 
Última edición:
blood

blood

No le abandones, el no lo haría contigo.
SuperMod
Cocinero
11 Ago 2015
4.894
4.861
7.243
Ehh!!!!
#2
Hola
Tengo un huawei p8 (gra-l09) con firma b190. Android 5.0.1 y miui 3

He desbloqueado el bootloader y quería meter el recovery twrp pero en este paso aunque me dice que esta bien no me sale el recovery, me sigue saliendo el recovery original.
Podéis ayudarme??
Mi intención es meter el recovery para poder rootear el teléfono y después poder usar alguna app que me cambie o enmascare la mac y poder conectar a un router que bloqueo la mac de mi móvil (trabajo)

Porfa podéis ayudarme?

Gracias

P.d: por si sirve de algo antes de desbloquear el bootloader intente hacerme root con el king root pero avecesniba y aveces no, el root checker me indica que soy aveces root pero aun así las apps de cambio de mac no me funcionan. Después empecé este proceso del recovery para meter desde el recovery el superSu y probar.
Hola,
Siempre después de meter el twrp hay que reiniciar en el para que este se quede instalado.
Una vez has terminado la instalación del recovery, que haces?
 
kmlot

kmlot

Simdualero de Bronce
30 Abr 2015
41
0
473
#3
Se reinicia solo.
La instalación la hago desde una consola de msdos que supuestamente automatiza el proceso
 
blood

blood

No le abandones, el no lo haría contigo.
SuperMod
Cocinero
11 Ago 2015
4.894
4.861
7.243
Ehh!!!!
#4
Pero le metes tu el comando para que reinicie en twrp?, también puedes intentar, cuando se este reiniciando pulsar ambas teclas de volumen y el de encendido a la vez, a ver si asi si entra en twrp.
 
kmlot

kmlot

Simdualero de Bronce
30 Abr 2015
41
0
473
#5
Es que no lo instala. Sale que todo el proceso es correcto pero al encenderse el teléfono, lo apago y al entrar al recovery me sale el oficial
 
blood

blood

No le abandones, el no lo haría contigo.
SuperMod
Cocinero
11 Ago 2015
4.894
4.861
7.243
Ehh!!!!
#6
Ahí tienes el problema, se inicia normal y entonces no se instala.
Después de indicarle el comando de instalar el twrp y una vez que termina y da el ok, tienes que poner este comando.

Reinciar en Modo Recovery:

fastboot boot twrp.img

O como te he dicho antes, cuando se apaga para reiniciar, apretar enseguida las teclas para que entre en modo recovery.
 
kmlot

kmlot

Simdualero de Bronce
30 Abr 2015
41
0
473
#7
Ahí tienes el problema, se inicia normal y entonces no se instala.
Después de indicarle el comando de instalar el twrp y una vez que termina y da el ok, tienes que poner este comando.

Reinciar en Modo Recovery:

fastboot boot twrp.img

O como te he dicho antes, cuando se apaga para reiniciar, apretar enseguida las teclas para que entre en modo recovery.
El comando no lo reconoce y aún apagando yo con los botones de entrar al recovery , entra pero no al twrp sino al del móvil original de.miui
 
blood

blood

No le abandones, el no lo haría contigo.
SuperMod
Cocinero
11 Ago 2015
4.894
4.861
7.243
Ehh!!!!
#8
A ver si es q no se ha desbloqueado el bootloader.

Para saber si hemos conseguido desbloquear el bootloader podemos usar el comando fastboot "fastboot oem device-info". No sé si funcionará en todos los terminales.
fastboot oem device-info

Dentro del resultado que da hay un apartado que pone "device unlocked" y aparece como "true" (desbloqueado) o "false" (bloqueado).

Tambien decirte q los huawei se desbloquean desde su pagina oficial y, al menos con el g620s q tenia, no hay q esperar. Conforme metes los datos te da el acceso para desbloquearlo.
 
kmlot

kmlot

Simdualero de Bronce
30 Abr 2015
41
0
473
#9
A ver si es q no se ha desbloqueado el bootloader.

Para saber si hemos conseguido desbloquear el bootloader podemos usar el comando fastboot "fastboot oem device-info". No sé si funcionará en todos los terminales.
fastboot oem device-info

Dentro del resultado que da hay un apartado que pone "device unlocked" y aparece como "true" (desbloqueado) o "false" (bloqueado).

Tambien decirte q los huawei se desbloquean desde su pagina oficial y, al menos con el g620s q tenia, no hay q esperar. Conforme metes los datos te da el acceso para desbloquearlo.
Pero el comando
Fastboot flash recovery "c/xxxx/twrp.img"

Al ejecutarlo me da okey
Aunque después nada.

Desde la consola este es el proceso completo que hago.

Adb devices

( ok)

Adb reboot bootloader

( el teléfono se apaga a fastboot y pone phone unlocked)

Fastboot flash recovery "c/xxxx/twrp.img"

( me da okey)

Aquí antes lo apagaba con los botones de entrar al recovery apretados y entraba al recovery original no al twrp

He probado el comando que me decías y no lo reconoce

Fastboot boot recovery twrp.img
 
blood

blood

No le abandones, el no lo haría contigo.
SuperMod
Cocinero
11 Ago 2015
4.894
4.861
7.243
Ehh!!!!
#10
No seria la primera vez q da ok y luego no sale el twrp pq el bootloader no esta abierto, por probar los comandos para ver si lo esta no pierdes nada.

Que twrp es el q estás intentando instalar?
 
kmlot

kmlot

Simdualero de Bronce
30 Abr 2015
41
0
473
#11
No seria la primera vez q da ok y luego no sale el twrp pq el bootloader no esta abierto, por probar los comandos para ver si lo esta no pierdes nada.

Que twrp es el q estás intentando instalar?
Logre poner el twrp, instale el supersu.
( ahora el telefono va mas lento)
Entro en el mac changer me la cambia y todo correcto, he reiniciado el teléfono para probar y ahora ya no me funciona el cambio de mac , he probado a comprobar lo del bootloader y me da un error (remote: command not allowed)
 
blood

blood

No le abandones, el no lo haría contigo.
SuperMod
Cocinero
11 Ago 2015
4.894
4.861
7.243
Ehh!!!!
#12
En tu dispositivo el comando para ver si esta abierto es fastboot oem get boot-info

El porque lo notas lento y no te va lo de la mac, ni idea, le has dado permisos al mac changer?
 

Miembros conectados

  • chapito
  • enrique.monfort
  • jitowin
  • segnini
  • DAAVIID
  • sersalvi
  • sirlancelot
  • emilio_rs
  • linusin87
  • Albein
  • makomako
  • qbphon
  • raultaboraz
  • vilamin
  • qbanito77
  • Gabrielflo
  • ye_moc
  • complicazio
  • francisco.fernandezvaldomar
  • sagimix
... y 32 más.