Problema al flashear ROMs. Creo que ya he probado todo. ¿Ideas?

S

sierra89

Simdualero de Bronce
11 Feb 2015
12
1
168
#1
Tengo un problema con mi F1, y ya le he dado vueltas durante (muchas) horas. A ver si a alguno se le ocurre por lo menos alguna nueva opción que pueda probar, porque ya no se me ocurre nada.

De repente empezaron a salir mensajes de error de absolutamente todas las apps instaladas, constantemente. El móvil así no se podía usar. Apagué y decidí reinstalar el SO, pero dio error.

Al intentar instalar una ROM en ZIP desde recovery no me deja porque no es capaz de montar las particiones de sistema y de cache. De hecho ni siquiera me deja hacer los wipes.

Al intentar con el flashtools, tnato en windows XP como en 7, empieza a cargar, pero me da error y no me dice porqué:
"BROM ERROR : S_BROM_CMD_JUMP_DA_FAIL (2035)
[HINT]:"
En windows 8 no me tira.

Probé con coolpad assistance y con YGDP las siguientes ROMs CPB, y tampoco:
4 2 029
4 2 041
4 2 020
4 4 016

El coolpad assistace hace correctamente esa especie de "parsing" del archivo, pero al cargarlo al telefono, llega hasta el 98% y luego en el movil da error de checksum, y en el PC sale una pantallita en chino con la cara sonriente pero simbolos chinos en rojo y grande. He probado con varias y a redescargarmelas también. Mismo resultado en windows XP, 7 y 8.

Con el YGDP en el PC con windows XP no me lo ejecuta, y en el que tiene windows 8 se queda en entering download mode.
En el windows 7 me carga, pero al acabar me da este error: "Encountered a hardware I/O error while accessing D:\TestRecord\CP8297W__0_NOSN_ ......"
Y la unidad D es el lector de CD/DVD que no estoy usando para nada y está vacío!

También he probado con la opción de adb sideload del recovery, desde el PC he usado el comando "adb sideload C:\AOSP.zip" siendo AOSP.zip la ROM, la consigue cargar pero luego da error diciendo que no puede montar cache, datos, sistema, etc.

Tras ver que todo esto no funcionaba, he intentado desde el flashtools la opción format+download ya que pensé que así podrían arreglarse las particiones.
Me ha realizado la operación completa y con el OK al final, pero el móvil no arranca, he probado después con download, y con el resto de opciones pero nada. El móvil queda con la pantalla en negro, ya no arranca ni en sistema, ni en recovery ni siquiera en bootloader. Me lo sigue reconociendo el flashtools en download mode, y permite flahear y dice cargar todo correctamente, pero no cambia nada.


¿Ideas de lo que puede ser y/o cómo arreglarlo? Ya he probado todo lo que se me ocurre.

PD: Tenía el recovery TWRP y la ROM laek v3, y con las que he probado ahora han sido las stock, la de laek y la de jonzalvo.

Resumen en negrita.
 
avecilla

avecilla

VIP+
Cocinero
3 Jul 2012
17.461
29.185
18.719
Sevilla
MI 9 T
#2
Vaya cantidad de cosas y mezclas que has realizado. Probaste con otro pc, que tenga Windows 7?
 
7

77chedu

Diamante
Cocinero
8 Sep 2014
2.604
1.511
5.229
Zaragoza, Spain
#3
Hola,

En el hilo de parches tenías una incidencia que me ha pasado a mi un par de veces con TWRP y probablemente, al meter la rom así te hubiese funcionado.

adb shell mount -t tmpfs none /sdcard

Y luego haces un adb push rom.zip /sdcard e instalas la rom
 
S

sierra89

Simdualero de Bronce
11 Feb 2015
12
1
168
#4
Hola,

En el hilo de parches tenías una incidencia que me ha pasado a mi un par de veces con TWRP y probablemente, al meter la rom así te hubiese funcionado.

adb shell mount -t tmpfs none /sdcard

Y luego haces un adb push rom.zip /sdcard e instalas la rom
Eso lo probé, pero no me funcionaba, me detectaba el dispositivo, pero cuando itentaba ejecutar esos comandos me decia que disconected.
Al final conseguí que tragase los comandos de carga de archivos como he indicado, pero ninguno más, esos no funcionaban.
 
S

sierra89

Simdualero de Bronce
11 Feb 2015
12
1
168
#5
Vaya cantidad de cosas y mezclas que has realizado. Probaste con otro pc, que tenga Windows 7?
Si, bueno, antes de preguntar por internet intento agotar los recursos que tengo disponibles jeje.
He probado con 2 PC con windows 7, en uno obtuve esos resultados, en el otro no iba nada bien, voy a volver a probar a reinstalarlo todo y flashear de nuevo con ese.
 
avecilla

avecilla

VIP+
Cocinero
3 Jul 2012
17.461
29.185
18.719
Sevilla
MI 9 T
#6
Ya contaras, la herramienta de coolpad suele dar muy buen resultado.

Enviado desde mi Elephone P7000 mediante Tapatalk
 
avecilla

avecilla

VIP+
Cocinero
3 Jul 2012
17.461
29.185
18.719
Sevilla
MI 9 T
#7
Hace poco a un user le dio resultado realizar format incluyendo bootloader. Es un riesgo.

Enviado desde mi Elephone P7000 mediante Tapatalk
 
S

sierra89

Simdualero de Bronce
11 Feb 2015
12
1
168
#8
Solucionado el tema de drivers en el otro PC, reinstalando todo desde 0. He vuelto a probar y nada mismos resultados que con el otro windows 7.
Los que restauran desde CPB siempre me dan fallo al final.
Los que restauran desde ZIP quedan descartados según el estado actual del móvil.
Pruebo ahora con format all + download en el flashtools desde el PC este con windows 7, incluyendo preloader y nada, sigue como estaba.
¿Es a eso a lo que te referías?
¿Sabes de algún otro procedimiento o forma de cargarlo que pueda probar?
¡Muchas gracias por la ayuda!
[DOUBLEPOST=1438370971][/DOUBLEPOST]Probado también con la "Soda's Factory Rom 015" en flashtools, en modo descarga y en modo formateo, con preloader y sin el. Sigue igual :(
 
avecilla

avecilla

VIP+
Cocinero
3 Jul 2012
17.461
29.185
18.719
Sevilla
MI 9 T
#9
No, en la pestaña de formateo, hay dos opciones una incluyendo bootloader y otra que no.

Enviado desde mi Elephone P7000 mediante Tapatalk
 
Axel Lexa

Axel Lexa

Platino
2 Dic 2014
307
42
1.947
Xiaomi Mi 4
#10
Creó que me paso mas o menos lo mismo.

Después de unos meses intentando de todo, lo di por perdido y lo reventé contra la pared
 
avecilla

avecilla

VIP+
Cocinero
3 Jul 2012
17.461
29.185
18.719
Sevilla
MI 9 T
#11
Creó que me paso mas o menos lo mismo.

Después de unos meses intentando de todo, lo di por perdido y lo reventé contra la pared
No es necesario llegar a esos extremos. Si esta averiado, siempre se puede vender para piezas y sacar algún beneficio.
 
S

sierra89

Simdualero de Bronce
11 Feb 2015
12
1
168
#12
Había hecho el formateo desde la pestaña de download, ya que una de las opciones es format&download.
Pero nada, así tampoco me va. He probado formateo con y sin bootloader.
Luego he probado a flashear la ROM completa, o a flashear solo bootloader. Y cualquier combinación de las anteriores. Y todo igual.
¡Lo curioso del caso es que el flasheo lo traga! Pero luego no arranca.
Dispongo en casa de otro móvil igual, por si pudiese usarlo de alguna forma para sacar archivos con los que arreglar este... si es que se da el caso de que se pueda hacer eso.
Creó que me paso mas o menos lo mismo.

Después de unos meses intentando de todo, lo di por perdido y lo reventé contra la pared
Creeme que por ganas es de lejos lo que más me apetece ahora mismo. Pero tirar así a la basura 130€ no es mi estilo, sobre todo después de la de horas que le he echado. Hoy me dolía la uña del pulgar derecho y no sabía lo que era... hasta que me puse de nuevo con el móvil. La tengo ya despegada de tanto abrir y cerrar la tapa, ¡malditos botones en la parte de la carcasa! jajaja
 

¿Qué tecnología no debe faltar en tu próximo móvil?

  • NFC

    Votos: 181 46,4%
  • Carga inalámbrica

    Votos: 140 35,9%
  • Carga ultra rápida

    Votos: 225 57,7%
  • 5G

    Votos: 171 43,8%
  • Al menos 3 cámaras principales

    Votos: 112 28,7%
  • Sensor TOF

    Votos: 70 17,9%
  • Lector de huellas

    Votos: 204 52,3%
  • USB tipo C

    Votos: 209 53,6%
  • Bluetooth

    Votos: 188 48,2%
  • Pantalla flexible

    Votos: 34 8,7%

Miembros conectados

  • Juan89Fran
  • chicoflow2716
  • mjuan
  • cjsegninir
  • canivi