Posible solucion para el gps (localizacion de satelites)

GAYAFON

ANDA... ALEGRAME EL DIA!!!
Super Moderador
27 Jul 2011
11.222
13.754
13.679
Quart de Poblet, Valencia, España
#1
Muchos habeis obtenido fallos en el gps (tarda en pillar satelites, se calienta mucho el movil buscando, simplemente no conecta bien o se desconecta a los pocos minutos)...

Bueno, siguiendo el paso que ha realizado con compa de xda, le he hecho una prueba al terminal y creo que está solucionado.

PASOS A SEGUIR:

- reinicia el telefono en modo recovery (yo tengo el recovery original, supongo que el custom recovery que puse en la review tendra estas opciones y mas...), ya sabeis, boton de encencido + bajar volumen.
- Dentro del menu, con las teclas de volumen, os desplazais hasta "item test" y la seleccionais con el boton tactil del home.
- Una vez dentro de "item test", buscais GPS y repetis lla misma accion.
- Ya dentro de GPS seleccionais que os haga un testeo (la 1ª opcion) y esperais a que lo haga. A mi me ha tardado 109 seg en pillar 5 satelites y los fija.
- Una vez ha acabado, dais al boton tactil de retroceso (el de la izquierda) hasta el menu principal.
- seleccionais reiniciar y listo.

Yo he hecho una prueba con la app GPS test despues de hacer esto y estos son los resultados:

dl.dropbox.com_u_84086578_Screenshot_2012_08_03_10_55_44.png
dl.dropbox.com_u_84086578_Screenshot_2012_08_03_10_56_09.png


dl.dropbox.com_u_84086578_Screenshot_2012_08_03_10_56_36.png
dl.dropbox.com_u_84086578_Screenshot_2012_08_03_10_56_57.png


Tengo que añadir que yo si tengo el archivo que puse en la review en la carpeta System/etc. No se si influirá. Probarlo de las dos maneras.

P.D: Esta prueba que incluida en la review...
 
Última edición por un moderador:

pollito33

Simdualero de Oro
17 Abr 2012
112
6
664
#2
Vamos a probar , espero los pille mejor y no se caliente.
 
20 Dic 2010
4.599
398
3.648
Asturias, España
#3
Muy interesante. Lástima que no parezca servir para todos los teléfonos similares, o al menos para el x310e con rom del zp100 que tengo ahora. Así como en mi viejo fg8 con MT6516 sí tenía acceso a ese menú, en el x310e no existe, y sólo existe el recovery , con power + subir volumen.
 

pollito33

Simdualero de Oro
17 Abr 2012
112
6
664
#4
He hecho todo lo ke indicas y el gps sigue igual apenas noto mejoria ,sigue calentandose y me sale el pantallazo diciendo que la bateria esta caliente y ke la quite.
 

GAYAFON

ANDA... ALEGRAME EL DIA!!!
Super Moderador
27 Jul 2011
11.222
13.754
13.679
Quart de Poblet, Valencia, España
#5
He hecho todo lo ke indicas y el gps sigue igual apenas noto mejoria ,sigue calentandose y me sale el pantallazo diciendo que la bateria esta caliente y ke la quite.
:wut:? Pues el mio mejoró y sin calentamientos... De hecho, a mi nunca se me ha calentado ( a ver, calentado hasta esas proporciones de salir un aviso...)... Y sigo con la rom original, no la actualizacion que puse en el post.
 

law81

Simdualero de Oro
23 Jun 2010
141
0
863
#6
GAYAFON

¿Puedes subir el gps.conf de tu x26i? llevo ya como 1000 segundos y solo me pilla dos satelites desde el principio
 

GAYAFON

ANDA... ALEGRAME EL DIA!!!
Super Moderador
27 Jul 2011
11.222
13.754
13.679
Quart de Poblet, Valencia, España
#7
GAYAFON

¿Puedes subir el gps.conf de tu x26i? llevo ya como 1000 segundos y solo me pilla dos satelites desde el principio
@law81, el gps.conf que tengo incluido es el de mi xperia arc:

Enlace roto eliminado

advierto que no a todos les ha funcionado. Alguno ni lo ha necesitado
 
Última edición por un moderador:

law81

Simdualero de Oro
23 Jun 2010
141
0
863
#8
@law81, el gps.conf que tengo incluido es el de mi xperia arc:

Enlace roto eliminado

advierto que no a todos les ha funcionado. Alguno ni lo ha necesitado

Si, lo vi en la review pero pensaba que al final modificaste el tuyo con otras soluciones. Probare a ver.
 
Última edición por un moderador:

law81

Simdualero de Oro
23 Jun 2010
141
0
863
#9
He probado lo de ir al recovery y hacer lo que pones mas arriba y funciona, en mi caso ha tardado mas de 3000 segundos (ahi en el pollete de la ventana, casi me voy a la cama con el olvidado ahi). Ahora con el gps test me aparecen muchos gps, de baja calidad, ninguno sobrepasa 40 pero al menos es algo.

Saludos y gracias por supuesto.
 

Jose.Mc

Simdualero de Oro
19 Jul 2012
247
43
816
Valencia
adf.ly
#10
buenas lo primero agradecer el tutorial, y lo segundo una consulta sobre el, ¿este Test se puede realizar sin a ver Rooteado el móvil previamente?

un saludo
jose.Mc
 

Jose.Mc

Simdualero de Oro
19 Jul 2012
247
43
816
Valencia
adf.ly
#12
si, claro. No es necesario
Gracias, pos voy a intentarlo luego te cuento como a salido el intento jeje

un saludo


PD: perfecto no a tardado mucho en fijarme 6 satélites voy a realizar la prueba con el Test GPS dentro de androy para comprobarlo

muchas gracias Funciona 100%!