PROBLEMA Botones capacitivos han dejado de funcionar

Melni

Simdualero de Oro
Mensajes
123
Puntos
938
Pues estaba yo todo contento con mi Redmi Note 2, después de haber trasteado con él durante un par de meses..., cuando de repente ha empezado a hacer cosas muy extrañas.

Primero, el interfaz ha empezado a fallar. Cuando entraba en la cámara e iba a hacer una foto, de repente, se salía de la apliación de la cámara y me volvía a la pantalla inicial. Tardaba como unos segundos, pero lo hacía siempre. Siempre volvía al menu principal. Luego comprobé que me pasaba también, aunque en menor medida, con otras apps. Además, continuamente me saltaba una notificación sobre el Modo de operación con una mano. Estaba todo el rato dándole a cancelar al mensaje que me salía. Muy extraño todo.

Dí por hecho que se trataba de un problema de la ROM y decidí limpiar la cache. Con el TWRP limpié:

- Dalvik Cache
- Cache

Reinicié el móvil pero el problema persistía. En este punto, le quité la batería y probé a reiniciar. El tema pareció solucionarse. Ya no me salían las notificaciones sobre el modo de operación con una mano, y me dejaba entrar en las apps, sin volver al menu principal, al cabo de unos segundos. El problema es que ahora, los 3 botones capacitivos de la parte inferior han dejado de funcionar!!!!.

Volví a pensar otra vez que se trataba de un problema de ROM y esta vez, decidí cambiar la ROM. A través del TWRP reflashée con la nueva ROM que sacó Xiaomi, ayer mismo. La V7.1.1.0.LHMMICK (MIUI7). Es decir, la estable global Versión 7.1.1. También limpié las caches:

- Dalvik Cache
- Data
- Cache

una vez antes de instalar la ROM y luego, otra vez, tras haberla instalado.

El problema persiste. Los botones de abajo, no funcionan. La pantalla va de maravilla. Las aplicaciones funcionar correctamente. Todo parece funcionar perfectamente excepto los botones. Alguna idea de qué puede estar pasando??. O directamente me planteo la opción de devolución a la tienda china de turno mientras esté en garantía, presuponiendo que se trata de un problema de Hardware?. Gracias a todos aquellos que habéis llegado hasta aquí después de este tostón de thread...
 

0Jos0

Ya es de día?
Diamante
Mensajes
9.033
Puntos
11.193
Yo probaría a meter alguna AOSP de Xancin o alguno de los repack de Avecilla haciendo wipes avanzados desde TWRP, dejando sólo la SD externa. Déjate los datos y la rom en externa.
Si sigue fallando pensaría en tramitar la garantía.
 

Melni

Simdualero de Oro
Mensajes
123
Puntos
938
Yo probaría a meter alguna AOSP de Xancin o alguno de los repack de Avecilla haciendo wipes avanzados desde TWRP, dejando sólo la SD externa. Déjate los datos y la rom en externa.
Si sigue fallando pensaría en tramitar la garantía.

OK. Gracias @0Jos0. Intentaré con alguna AOSP de Xancin/Avecilla. ¿Me recomiendas alguna en particular?.
 

Melni

Simdualero de Oro
Mensajes
123
Puntos
938
Nas, estoy intentando instalar las ROMs comentadas y obtengo un mensaje muy raro en MiFlash. Algo que no me había salido nunca, a pesar de haber instalado varias veces las diferentes ROMs. Me aparece:
"Mismatching image and device error". Sale todo el rato, así que no tengo opciones de flashear via FastBoot. ¿Alguna idea de por qué sale este mensaje?. El log de MiFlash es:

[00001808]CreateManagedObject(1273): Error no especificado(0x80131604)
[00001808]GetFactoryObject(1317): Error no especificado(0x80131604)
[00001808]CreateManagedObject(1273): Error no especificado(0x80131604)
[00001808]GetFactoryObject(1317): Error no especificado(0x80131604)
[00001808]GetFactoryObject(1338): El servicio especificado no existe.(0x800704db)
[00001808]GetSearchPath(1393): El servicio especificado no existe.(0x800704db)
[0000163C]T4DE6DR499999999 0.00 execute flash_all_except_storage.bat
[0000163C]CScriptReport::smile:oWork(397): El sistema no puede encontrar el archivo especificado.(0x80070002)
[0000163C]GetFactoryObject(1338): El servicio especificado no existe.(0x800704db)
[0000163C]SaveFlashResult(1359): El servicio especificado no existe.(0x800704db)
[00001808]GetFactoryObject(1338): El servicio especificado no existe.(0x800704db)
[00001808]GetSearchPath(1393): El servicio especificado no existe.(0x800704db)
[00000D4C]T4DE6DR499999999 0.00 execute C:\a\flash_all.bat
[00000D4C]T4DE6DR499999999 0.03
[00000D4C]T4DE6DR499999999 0.03 $fastboot -s T4DE6DR499999999 getvar product 2>&1 | findstr /r /c:"^product: LCSH6795_LWT_L" || fastboot getvar product 2>&1 | findstr /r /c:"^product: LCSH6795_LWT_CU" ||
[00000D4C]T4DE6DR499999999 0.27 Missmatching image and device error
[00000D4C]CScriptReport::smile:oWork(413): Error no especificado(0x80004005)
[00000D4C]GetFactoryObject(1338): El servicio especificado no existe.(0x800704db)
[00000D4C]SaveFlashResult(1359): El servicio especificado no existe.(0x800704db)
 

mopas

Simdualero de Bronce
Mensajes
24
Puntos
474
Móvil
THL T200C
Hola Melni, puede ser que hayas desactivado los botones? Desde los accesos rápidos hay un botón que pone botones y si lo tocas te desactiva los botones, para activar toca botón de encendido y botón home simultaneamente. A ver si es eso, suerte.

Enviado desde mi THL T200C
 

Melni

Simdualero de Oro
Mensajes
123
Puntos
938
Tienes que usar twrp. O mejor dicho cambiar de recovery a twrp.

Enviado desde mi Redmi Note 2 mediante Tapatalk

@avecilla, el problema es que no puedo instalar el TWRP en este momento. Justo antes de empezar a intentar la instalación vía FastBoot con vuestras ROMs, tenía ya instalado el TWRP. Desde el TWRP, probé a instalar la global estable de "en.miui.com", la versión 7.1.1. La instalé correctamente y desde ese momento, me reemplazó el TWRP por el MiRecovery y ahí empezó todo el problema de no poder hacer flasheos. Desde que tengo la 7.1.1, ya no puedo utilizar FastBoot para flashear. No entiendo por qué, pero no me deja.

Ayer probé a instalar la Global Developer versión 7.1.1. desde el MiRecovery y sí que me dejó hacerlo. Pero luego, cuando se supone que ya soy Root e intento instalar el TWRP, ya no me deja. Me sale el mensaje de "Update.zip verification failure". Con lo cual, tengo cerrada la opción de instalar el TWRP de ese modo. En este punto, con la developer global versión 7.1.1. también he intentado instalar otras ROMs mediante FastBoot, pero tampoco me deja. Es decir, ni con la Estable, ni cona Developer version 7.1.1. me ha dejado hacer FastBoot. No entiendo cuál es el problema, pero parece que esta versión me ha capado esa opción. Aunque no sé, igual tengo algún problema anterior que se está enmascarando con la instalación de la nueva versión.
 

Melni

Simdualero de Oro
Mensajes
123
Puntos
938
Hola Melni, puede ser que hayas desactivado los botones? Desde los accesos rápidos hay un botón que pone botones y si lo tocas te desactiva los botones, para activar toca botón de encendido y botón home simultaneamente. A ver si es eso, suerte.

Enviado desde mi THL T200C

Gracias @mopas. Sí lo he comprado pero no están desactivados. Aunque igual pueden ir por ahí los tiros. Igual en el fichero de configuración de. sistema, aparece esa opción como desactivada y luego, por lo que sea, el fichero no se actualiza cuando lo cambias y siempre están desactivados. No sé, aunque vamos, mucho suponer por mi parte, je, je. Gracias de todas formas.
 

Melni

Simdualero de Oro
Mensajes
123
Puntos
938
Porqué no pruebas a instalar una rom por SPFlashtool?.

TUTORIAL - Recuperar tu redmi note 2 de un brickeo


Lo del recovery stock está explicado aquí:

TUTORIAL - Instalación TWRP


De todas formas, si ahora eres root, también podrías instalar TWRP por flashify:

Flashify (for root users) - Aplicaciones de Android en Google Play

@0Jos0. Parece que al final, no tenía root. He probado con varias ROMs, que no me dan el error de "Verification failure" desde MiRecovery, pero ninguna parece ser root. Así que creo que voy a intentar la instalación desde el SPFalshtool. Muchas gracias por los enlaces.
 

Del blog

  • ¿Qué es Plex y cómo se instala?
    Wed, 14 Dec 2022 16:02:34 CET
    ¿Alguna vez has deseado tener todas tus películas, series de televisión, música, fotos y contenido de vídeo en un solo lugar? Si es así, entonces Plex es la solución perfecta para ti. Plex es una plat ...
  • Mini pc NiPoGi GK3PRO – review y opinión
    Sun, 11 Dec 2022 01:30:40 CET
    Tenemos en nuestras manos una auténtica maravilla, se trata de un mini pc de la marca NiPoGi que trae en su interior un procesador Intel 5105 de 4 núcleos y 4 hilos de muy bajo consumo pero con unas p ...
  • Review Phasak PH9406 de 600VA/360W
    Thu, 01 Dec 2022 13:12:27 CET
    Vamos a poner a prueba un SAI interactivo de la marca Phasak, uno de sus modelos más asequibles y que sobre papel tiene características bastante buenas, un sistema que recomendamos a todos en casa par ...
  • Los mejores smartphones Android de gama alta en noviembre de 2022
    Sun, 27 Nov 2022 12:14:01 CET
    Los mejores smartphones Android de gama alta en noviembre de 2022 Ya el Black Friday ha quedado atrás y apuntamos directamente a Cyber Monday como el próximo evento importante de rebajas, y es que ya ...
  • Mejores mini pc de este 2022
    Sat, 26 Nov 2022 13:01:42 CET
    Queda poco para que finalice el 2022 y ya tenemos el listado de los mejores mini pc que han sido lanzados hasta la fecha, con sus características, pros y contras así cómo los motivos por los que pensa ...

¿El cierre de Stadia ha afectado tu confianza en los futuros productos de Google?

  • Si, me costará apostar por un nuevo producto de google

  • Sólo un poco, no es para exagerar

  • Para nada, ha sido necesario que cerrase

  • No sé que es Stadia


Los resultados solo son visibles tras votar.
Top 21 Baterías solares para móvil al mejor precio
Arriba